PPPOED packet

Unanswered Question
Jun 10th, 2009


I have a L2 scenerio on cisco switches 4507 like.

RAS Router-->Cisco 4507 Switch A(Trunk Port)--->Cisco 4507 Switch A(trunk port) with another 4507 switch B---> Access Port on 4507 Switch B (from where one IP DSLAM connected).

Problem is that we are not getting PPPoEd packet from this IP dslam on Switch B access port, i.e it is dropping in between DSLAM to Cisco Acess port Switch B.

But when we are giving command "switchport trunk native vlan XX" on the cisco switch B access port that PPPOed packet on coming on the port. But as we can't give this Switchport trunk native command on backend trunk link as all other / many vlans also allowed.

Wht is the reasn for PPPoed packet not coming on acess port. Where may be the problem.

Note :- We have some othe IPDLSAM also which are connected on the same switch with same backend configs (but with other Vlan) are responfding fine. i.e PPPoED packet coming properly with any additional configs or command line Switchport trunk native".


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Giuseppe Larosa Wed, 06/10/2009 - 23:51

Hello Jimmy,

this makes me think of a L2 MTU issue:

the difference when you use

switchport trunk native vlan XX

is the 4 bytes 802.1Q header is not present.

PPPoE introduces an 8 byte header.

I wouldn't expect PPPoE Discovery to be a big frame but these simptoms lead in this direction.

if so you may want to modify the MTU on SwitchB port and/or on connected device

check if MTU is 1492 on involved interfaces

Hope to help


cisco.net Thu, 06/11/2009 - 01:20


Cisco 4507 switch B is not supporting ip mtu comand.

Cisco_4507(config-if)#ip ?

Interface IP configuration subcommands:

access-group Specify access control for packets

arp Configure ARP features

dhcp DHCP

igmp IGMP interface commands

verify verify

cisco.net Thu, 06/11/2009 - 21:50


I have found command for MTU setting on Gig interface. "mtu <1500-9198>.

But it is showing message that Gig does not support user define MTU.

Gig int. is by default taking MTU of 1500.


Giuseppe Larosa Sat, 06/13/2009 - 04:44

Hello Jimmy,

I was meaning L2 MTU not ip mtu.

You have two options:

or the used side has an ip mtu 1492 on the PPPoE interface(s).

or you need to find a way to increase MTU on the C4507.

if mtu command is not supported on gigabit interface you may want to use

system mtu

be aware that this command has global effects that can impact on routing protocol adjacencies if the device is used as multilayer switch

Hope to help


Paolo Bevilacqua Sat, 06/13/2009 - 10:41

I don't think it's an MTU issue.

PPPoE packets are 1500 bytes like any other.

Perhaps since PPPoE is not IP you should check that you're bridging correctly.

cisco.net Sat, 06/13/2009 - 22:02


May be u r correct, But we have closely checked all the configs, And as mentioned in first post ..other working sites with same configs & scenerio is working fine. But getting this problem with some particular sites only.


cisco.net Tue, 06/16/2009 - 23:39

Hii Netpros,

Kindly revert if anyone is aware about the issue or had faced any such issues.



This Discussion