Lms Device Disovery not happening

Unanswered Question
Jun 11th, 2009
User Badges:

In LMS 3.1.

device discovery is not happenning.

It says ANI server is down.I checked in process, it shows the status of ANI server as "failed to run". I tried to start,after 2-3 mins again status shows as "failed to run".


Please find the logs of ANI attached



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 06/11/2009 - 08:53
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This error should not be possible with LMS 3.1. Confirm what version of Campus Manager you have.

Joe Clarke Thu, 06/11/2009 - 21:29
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post the output of the pdshow command.

scott.lorenzen@... Wed, 06/24/2009 - 03:54
User Badges:

I am also having the same issue. When I run pdshow I am showing the following for the ANIServer


Process= ANIServer

State = Failed to run

Pid = 0

RC = -1

Signo = 1073741823

Start = N/A

Stop = 6/24/2009 6:09:42 AM

Core = Not applicable

Info = Application failed or was registered incorrectly.


Please let me know if there is anything else I can look at to get this going.

Joe Clarke Wed, 06/24/2009 - 09:04
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Start a new thread for your issue.

scott.lorenzen@... Fri, 06/26/2009 - 06:02
User Badges:

As I found out in our case the file ANIServer.properties was corrupted. If you go to the install folder Program Files\CSCOpx\campus\etc\cwsi and look for this file you should see two files in the folder. If your file 1 does not look anything like the file 2 then yours is corrupted.


1) ANIServer.properties

2) ANIServer.properties.orig


We renamed the first to .old then copy the .orig and rename it by removing the copy of and the .orig.


You will then need to modify the ANIServer.properties file and add to the line


1) AniName=ANIServer6.0-

2) DEVICESROOT=C:\\PROGRA~1\\CSCOpx\\campus\\lib\\classpath

3) DEVICESPACKAGE=com.cisco.nm.ani.server.devices

LogMsg.logfile=C:/PROGRA~1/CSCOpx/log\\ani.log


Once you have done this then from a command prompt c:\> net stop crmdmgtd && net start crmdmgtd


Then c:\> pdshow


The cursor will just sit there until all processes are started. Once they are started and you are back at the c:\> _ then login to CW and go to CS and check to make sure the process is started.


This worked for me and it is now running.

Actions

This Discussion