Problem connecting my 1811 to Rogers internet high speed

Unanswered Question
Jun 11th, 2009
User Badges:

Hi,

It's the first time i'm connecting my router to a Rogers Internet High speed (DOCSIS technologie) and i'm not getting any Internet..

Here is my config:

!

interface FastEthernet0

description Rogers

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Vlan1

ip address 10.x.x.97 255.255.255.192

ip nat inside

ip virtual-reassembly

ip route 0.0.0.0 0.0.0.0 F0

!

access-list 1 permit 10.x.x.64 0.0.0.63

!

ip nat inside source route-map NAT_Rogers interface FastEthernet0 overload

route-map NAT_Rogers permit 10

match ip address 1

match interface FastEthernet0

!

the thing is that i m getting a public ip adress from the provider but nobody can ping it and i m not able to go through internet and my VPNs are not working either.

Im running a (C181X-ADVIPSERVICESK9-M), Version 12.4(24)T.

I already checked with their technical support and the connection is fine if i put another router a dlink or a linksys the Internet is working just fine.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mlitka Thu, 06/11/2009 - 09:55
User Badges:

What is the purpose of the 'match interface fastethernet0' in your route-map?

I-Routes45 Thu, 06/11/2009 - 11:53
User Badges:

that is my way to say that i m nating my permitted traffic on access-list 1 with the ISP in FastEthernet0.

all i want is an exemple to how to set a Rogers Internet high speed in Ontario.

someone says to me that i should replace my default route :

ip route 0.0.0.0 0.0.0.0 f0 with ip route 0.0.0.0 0.0.0.0 x.x.x.x

where x.x.x.x is the default gateway from Rogers.

mlitka Thu, 06/11/2009 - 11:55
User Badges:

Remove that match statement. It is not needed.


The problem is you are telling it to NAT the address that is assigned to the FastEthernet0 interface as well, which is probably causing a loop.


I-Routes45 Thu, 06/11/2009 - 12:27
User Badges:

i did remove it but no change..

i'm getting an ip address from Rogers but i can t go to Internet with that. do you have any exemple for configuring a cisco 1811 with Rogers wich is working please ?

nicblais1 Thu, 06/11/2009 - 12:32
User Badges:

Can you ping the gateway the cable modem gives you? Also, you did reboot the modem so that the router is associated to the modem right?


I have a similar setup:


interface FastEthernet4

description $FW_OUTSIDE$

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

no cdp enable

end


interface Vlan10

description $FW_INSIDE$

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

end


ip route 0.0.0.0 0.0.0.0 fa4

ip nat inside source list 1 interface FastEthernet4 overload

access-list 1 permit 192.168.1.0 0.0.0.255




Edison Ortiz Thu, 06/11/2009 - 12:51
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Remove that match statement. It is not needed.


The problem is you are telling it to NAT the address that is assigned to the FastEthernet0 interface as well, which is probably causing a loop.


It is not creating a loop. The 2 match statements in the route-map are specifying to only NAT when the source and destination are valid. The first match is the source (the ACL) and the destination is the interface as it has the 'ip nat outside' command.


If the interface goes physically down, then the route-map becomes invalid and no NAT will occur.


We need to see the routing table and nat translation from this router as well as the result from pinging from the router to the internet - say: ping 4.2.2.1


___


Edison.

Actions

This Discussion