CUCM6.1 help with mgcp E1 desperately needed

Unanswered Question
Jun 11th, 2009

Hi, I have been struggling for hours on this one. I have new installation with a mgcp gateway with an E1. My E1 is up my gateway is registered. But i can not call out, i dial from a phone and get reorder tone after a second or two. I have debugs on gateway isdn q931 and q932 and ccm-manager backhaul, I see normal q932 messages but never any q931. I have checked calling search space and they are ok, dialled analyser also confirms route pattern is ok.

I am not sure where to continue looking, any ideas welcome.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Paolo Bevilacqua Thu, 06/11/2009 - 10:09

Try calling from outside with debug isdn q931. If you don't see anything, it's telco problem.

ReadersUK Thu, 06/11/2009 - 12:34

Hi Paolo

I have lost count of the number of times you have helped me on this forum, so want to take the time to say thanks.

I get q931 from outside calls and my gut feel is that this is a callmanager problem


Nicholas Matthews Thu, 06/11/2009 - 10:18

Hi Colin,

You have a CUCM routing problem.

Please make sure that the partition your route pattern that points to the gateway is included in the CSS of the line and phone that you're testing from.

If the gateway is not getting q931 it's because CUCM isn't sending it.


ReadersUK Thu, 06/11/2009 - 12:38

Hi Nick

Im using the line and device method of CSS to control barring, so my phone device has CSS with gateway PT in it but the line does not, however i did add it to the line as a test. Its very late here in moscow and im tired and dont trust my own programming so will double check tomorrow after some sleep.


Nicholas Matthews Thu, 06/11/2009 - 12:51

Hi Colin,

The gateway isn't actually in a partition but actually the route pattern. Just want to clarify on that.

If you're showing registered on both sides you're ok on the domain name.


ReadersUK Thu, 06/11/2009 - 12:41

Hi jose

I am using domain name and did set it up in gateway config, and mgcp is working fine i can control 8 fxs ports on the same gateway so i know mgcp is working.


Ajay Singh Thu, 06/11/2009 - 22:39

Hi...Can you try below mentioned things:

1. Call from IP Phone on any PSTN no and turn on debug 931, and check whether calls hit the gateway for outbound calls or not. Checkl the same for inbound calls also.

2. The route pattern you have made for PSTN calling, check whether you have assigned the right gateway/endpoint to that or not.

3.Ensure your route pattern CSS and PT are in match with Phone line CSS and PT. Its not mandatory to assign CSS and PT on device level, if you are assigning them on Line level, because line gets preference over device.

4. On the gateway page of CCM, what icon you are seeing on E1 end point. If its a question mark sign, then there is problem..

Let me knw after u troubleshoot all this..i had faced the same issue which i had resolved with some troubleshooting :)

ReadersUK Fri, 06/12/2009 - 00:22

Hi Ajay

before i read your reply i decided to delete the mgcp setup and reconfigure to H323. I still face the same problem. However i decided to try and concentrate on the incoming since its the only way i can generate any q931 debugs.

so below is an incoming call to my gateway. It fails every time.

Jun 12 08:17:03.692: ISDN Se0/1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0F

Bearer Capability i = 0x9090A2

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xE980830F

Exclusive, Interface 0, Channel 15

Facility i = 0x11FAA10D02010102020100CC0400000534

- Unknown Service Discriminator 17

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x2183, '8412321632'

Plan:ISDN, Type:National

Called Party Number i = 0xB9, '2585559'

Plan:Private, Type:Network specific

Jun 12 08:17:03.696: ISDN Se0/1/0:15 Q931: Received SETUP callref = 0x800F callID = 0x0034 switch = primary-net5 interf

Jun 12 08:17:03.696: ISDN Se0/1/0:15 **ERROR**: CCPMSG_InCall: ChannelID IE invalid 100(0x64) rejecting call

Jun 12 08:17:03.696: ISDN Se0/1/0:15 **ERROR**: call_facility_invoke: no idb found for call id 0x34

Jun 12 08:17:03.696: ISDN Se0/1/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x800F

Cause i = 0x80E418 - Invalid information element contents

any help is welcome.


ReadersUK Fri, 06/12/2009 - 01:20

Hi All

I have attached some debugs which show calls from an internal extension 70072221 getting to my gateway before failing. i debugged H323 and voice ccapi.

It at least proves my calling search spaces are working.

Ajay Singh Fri, 06/12/2009 - 01:24

Can you check switch type configuration in your router??there might be some configuration setting mismatch with router E1 end or else you have to check with telco.

ReadersUK Fri, 06/12/2009 - 02:21

Hi Ajay

I set switchtype to isdn switch-type primary-net5 which is the standard here. It's a national holiday in russia so i am unable to call telco. My problems just keep getting worse


Marcelo Almeida... Sat, 06/13/2009 - 18:05

Hi Colin,

I saw the same problem on a client before, we double check everything, but we can not call out.

We decided to check the client's CCM installation, using our lab's CCM. With the lab's CCM we start to call out.

We re-install the client's CCM from the DVD and after that we start to call out.

Conclusion ... we have some kind of problem on the CCM HD installation.

Hope this can help you.

ReadersUK Mon, 06/15/2009 - 00:04

Thanks for your reply

However the CCM is working with another two gateways with no problem so I dont think its as serious as reinstalling the software.



Paolo Bevilacqua Sun, 06/14/2009 - 00:37

That seems to be the problem:

Channel ID i = 0xE980830F

Exclusive, Interface 0, Channel 15

Facility i = 0x11FAA10D02010102020100CC0400000534

- Unknown Service Discriminator 17

have telco check on that.

ReadersUK Mon, 06/15/2009 - 00:10

Hi Paolo

I prepared a mail with the debug details for the Russian telco on Friday, unfortunately they were all on national holiday Friday. I'm now back home in the UK and have to rely on my Russian colleagues to talk with the provider on my behalf. Ill post the results here once i get them.



ReadersUK Mon, 06/29/2009 - 00:55

I want to say thanks to all those who helped but this issue has now been resolved. I finally got to talk with the Russian isdn engineer in the central office and he changed a parameter he called "disconnect signalisation security" and the circuit is now working fine.


This Discussion