WAAS optimizing high application turns

Unanswered Question
Jun 11th, 2009
User Badges:

Hello Everyone,


I have an Oracle server that's located in South America, Chile. The client sits in Rye, NY. The latency to the server is about 238ms. We are using 2 WAE-7371(s) in Rye and 1 WAE-674 in Chile. All devices are running version 4.1.1d. The overall performance is very slow for the client accessing the Oracle database. The client says it's taking minutes to bring up the reports; everything he does takes a very long time. This is the first time he is accessing the Oracle DB from Rye. Now, I was hoping the WAAS can help out with optimizing the Oracle traffic; it's getting full TFO acceleration. However, after taking a couple of packet captures from the client, there are about 8,000 application turns.

Is there any tweaking I can perform on the WAAS that may help this at all? Is there a layer-7 accelerator for Oracle database? Do I need to look at fine tuning the TCP send/receive buffer settings? The default TCP send/receive buffer settings is set to adaptive.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dstolt Thu, 06/18/2009 - 18:09
User Badges:
  • Cisco Employee,

John,


Without knowing more about the traffic, its very difficult to actually give you more advice about this.


the application traffic is very short, bursty traffic, chances are we can only some some compression on it (if it's not encrypted, etc.).


If the traffic is HTTP, that it's definitely possible that the HTTP adapter in 4.1.x will assist so you don't have 100s of HTTP setups going on for the same client. If it's HTTP using a non-standard tcp port, then try adding that port to the HTTP adapter in the application profiles and see if that helps. If it's not HTTP, then maybe try different optimization settings (TFO only, etc) to see if that helps as well.


We can dig a little more if you get stats of the individual connections off the WAEs (TFO, DRE, etc.)


Dan

johnwallace Fri, 06/26/2009 - 18:50
User Badges:

We have the same situation running Onbase sql calls. We tried altering the setting from pass through on up. No luck for getting better throughput. Our are ms-sql calls with 65ms latency

Actions

This Discussion