Question related to OSPF process ID

Unanswered Question
Jun 11th, 2009
User Badges:

Hello Netpros,


My question is related to the OSPF different process ids running on a single router.Do there is any method to synchronize two different OSPF ids advertised network to the neighbor routing table.


R1#sh ip ospf database


OSPF Router with ID (10.10.2.1) (Process ID 12)


Router Link States (Area 0)


Link ID ADV Router Age Seq# Checksum Link count

10.10.2.1 10.10.2.1 192 0x80000001 0x00548B 1


OSPF Router with ID (2.2.2.2) (Process ID 28)


Router Link States (Area 0)


Link ID ADV Router Age Seq# Checksum Link count

1.1.1.1 1.1.1.1 1042 0x80000008 0x00E943 4

2.2.2.2 2.2.2.2 1559 0x80000004 0x0038F1 4

3.3.3.3 3.3.3.3 1525 0x80000003 0x00F82B 4



R1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


9.0.0.0/32 is subnetted, 1 subnets

C 9.9.9.9 is directly connected, Loopback9

10.0.0.0/32 is subnetted, 6 subnets

O 10.10.2.2 [110/65] via 10.10.2.2, 00:48:18, Serial0/2

O 10.10.1.1 [110/65] via 10.10.0.1, 00:48:18, Serial0/0

O 10.10.0.1 [110/65] via 10.10.0.1, 00:48:18, Serial0/0

C 10.10.0.2 is directly connected, Loopback0

C 10.10.2.1 is directly connected, Loopback2

O 10.10.1.2 [110/65] via 10.10.2.2, 00:48:18, Serial0/2





R2#sh ip ospf database


OSPF Router with ID (10.10.2.2) (Process ID 12)


Router Link States (Area 0)


Link ID ADV Router Age Seq# Checksum Link count

10.10.2.2 10.10.2.2 690 0x80000002 0x0020C0 1


OSPF Router with ID (3.3.3.3) (Process ID 28)


Router Link States (Area 0)


Link ID ADV Router Age Seq# Checksum Link count

1.1.1.1 1.1.1.1 1103 0x80000008 0x00E943 4

2.2.2.2 2.2.2.2 1620 0x80000004 0x0038F1 4

3.3.3.3 3.3.3.3 1584 0x80000003 0x00F82B 4



R2#sh ip route

R2#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


8.0.0.0/32 is subnetted, 1 subnets

C 8.8.8.8 is directly connected, Loopback8

10.0.0.0/32 is subnetted, 6 subnets

C 10.10.2.2 is directly connected, Loopback2

O 10.10.1.1 [110/65] via 10.10.1.1, 00:49:02, Serial0/1

O 10.10.0.1 [110/65] via 10.10.1.1, 00:49:02, Serial0/1

O 10.10.0.2 [110/65] via 10.10.2.1, 00:49:02, Serial0/2

O 10.10.2.1 [110/65] via 10.10.2.1, 00:49:02, Serial0/2

C 10.10.1.2 is directly connected, Loopback0







I know OSPF process id is used to identify the OSPF routing process and it kept different database table for each process.But just for a curiosity is this possible?



Thanks

Prasad

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Manish Prasad Thu, 06/11/2009 - 13:40
User Badges:

For more clarification


R1#sh run | be ospf

router ospf 28

router-id 2.2.2.2

log-adjacency-changes

network 10.10.0.2 0.0.0.0 area 0

network 10.10.2.1 0.0.0.0 area 0

!

router ospf 12

log-adjacency-changes

network 9.9.9.9 0.0.0.0 area 0





R2#sh run | be ospf

router ospf 28

router-id 3.3.3.3

log-adjacency-changes

network 10.10.1.2 0.0.0.0 area 0

network 10.10.2.2 0.0.0.0 area 0

!

router ospf 12

log-adjacency-changes

network 8.8.8.8 0.0.0.0 area 0

!

ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane



Thanks

Prasad




Edison Ortiz Thu, 06/11/2009 - 14:05
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You can't synchronize them but you can redistribute between OSPF processes to have routes from each OSPF database distributed to their respective neighbors.


HTH,


__


Edison.

Manish Prasad Thu, 06/11/2009 - 14:12
User Badges:

Thank You Edison.


Could you give me any example how to redistribute between OSPF processes.


One more question when i was trying to add one more OSPF process on a single router i get some messages , please can you explain this....



"*Mar 1 00:32:24.755: OSPF: Start redist-scanning

*Mar 1 00:32:24.755: OSPF: Scan the RIB for both redistribution and translation

*Mar 1 00:32:24.775: OSPF: End scanning, Elapsed time 20ms^Z"



Thanks

Prasad

Edison Ortiz Thu, 06/11/2009 - 14:16
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

router ospf 28

router-id 2.2.2.2

redistribute ospf 12 subnets

log-adjacency-changes

network 10.10.0.2 0.0.0.0 area 0

network 10.10.2.1 0.0.0.0 area 0

!

router ospf 12

log-adjacency-changes

redistribute ospf 28 subnets

network 9.9.9.9 0.0.0.0 area 0


How many OSPF processes are you adding? If more than 2, then you have a network design problem.


Actually, what's the reason for needing 2 OSPF processes now?


Manish Prasad Thu, 06/11/2009 - 15:12
User Badges:

OSPF hello packets do not contains process id.


So when the hello packet is exchanged with matching all the required field then atleast the neighbor router will make a INIT state relationship with this router(Process id doesn't matter here).


If so then why the neighborhood relationship table is not showing the adjacency with the router id 10.10.2.2..



R1#sh ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface

3.3.3.3 0 FULL/ - 00:00:36 10.10.2.2 Serial0/2

1.1.1.1 0 FULL/ - 00:00:38 10.10.0.1 Serial0/0




Thanks

Prasad


Harold Ritter Thu, 06/11/2009 - 16:06
User Badges:
  • Cisco Employee,

Prasad,


Each interface can only belong to one ospf process. So the neighbor relationship will be established one of the two process ids for a given interface.


show ip ospf interface tells you which process id owns the interface.


Regards

Actions

This Discussion