Redistribution:

Answered Question
Jun 11th, 2009
User Badges:

Looking at the correct way to redistribut EIGRP and Static routes into BGP. Please see below config.


ip route 86.43.157.69 255.255.255.255 2.153.42.29 254



router eigrp 90

passive-interface default

no passive-interface g0/0

no auto-summary

netork 2.153.83.0 0.0.0.255

netork 2.153.84.0 0.0.0.255

netork 2.153.85.0 0.0.0.255

netork 2.153.86.0 0.0.0.255

netork 2.153.87.0 0.0.0.255



router bgp 65500

no synchronization

bgp log-neighbor-changes

neighbor 86.43.157.37 remote-as 5466

no auto-summary


Please advise

C



Correct Answer by Joseph W. Doherty about 7 years 11 months ago

What Jon suggests, indeed works. However, it dumps all of your statics and IGP routes into BGP, unless you filter what's being redistributed.


Another method is to use network statements within the BGP router configuration. This redistributes routes only already in the IP routing table that match the network statement. I.e., it might be little clearer what networks you want BGP to advertise.


(NB: I don't work with BGP that often, and I'm doing this from memory. Anyone that notices a mistake, please post a correction - thanks.)


e.g.

router bgp 65500

.

.

network 2.153.83.0 mask 255.255.255.0

network 2.153.84.0 mask 255.255.255.0

network 2.153.85.0 mask 255.255.255.0

network 2.153.86.0 mask 255.255.255.0

network 2.153.87.0 mask 255.255.255.0

network 86.43.157.69 mask 255.255.255.255


Often when working with BGP, we want to avoid route churn that might be caused by IGP routes coming and going. Also, we might want to only advertise a aggregate prefix for an address block. Either/both can be accomplished by using a BGP network statement that matches a static route which covers the addresses used by your IGP.


e.g.

ip route 2.153.83.0 255.255.255.0 null 0 200

ip route 2.153.84.0 255.255.252.0 null 0 200


router bgp 65500

.

.

network 2.153.83.0 mask 255.255.255.0

network 2.153.84.0 mask 255.255.252.0

network 86.43.157.69 mask 255.255.255.255


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Jon Marshall Thu, 06/11/2009 - 15:23
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Colm


Simply add in the following 2 redistribute statements -


router bgp 65500

no synchronization

bgp log-neighbor-changes

neighbor 86.43.157.37 remote-as 5466

redistribute eigrp 90

redistribute static

no auto-summary


You can influence which routes are redistributed with route-maps and you can specifiy a metric for each redistribute statement but the above would be enough.


Jon

Correct Answer
Joseph W. Doherty Thu, 06/11/2009 - 17:09
User Badges:
  • Super Bronze, 10000 points or more

What Jon suggests, indeed works. However, it dumps all of your statics and IGP routes into BGP, unless you filter what's being redistributed.


Another method is to use network statements within the BGP router configuration. This redistributes routes only already in the IP routing table that match the network statement. I.e., it might be little clearer what networks you want BGP to advertise.


(NB: I don't work with BGP that often, and I'm doing this from memory. Anyone that notices a mistake, please post a correction - thanks.)


e.g.

router bgp 65500

.

.

network 2.153.83.0 mask 255.255.255.0

network 2.153.84.0 mask 255.255.255.0

network 2.153.85.0 mask 255.255.255.0

network 2.153.86.0 mask 255.255.255.0

network 2.153.87.0 mask 255.255.255.0

network 86.43.157.69 mask 255.255.255.255


Often when working with BGP, we want to avoid route churn that might be caused by IGP routes coming and going. Also, we might want to only advertise a aggregate prefix for an address block. Either/both can be accomplished by using a BGP network statement that matches a static route which covers the addresses used by your IGP.


e.g.

ip route 2.153.83.0 255.255.255.0 null 0 200

ip route 2.153.84.0 255.255.252.0 null 0 200


router bgp 65500

.

.

network 2.153.83.0 mask 255.255.255.0

network 2.153.84.0 mask 255.255.252.0

network 86.43.157.69 mask 255.255.255.255


Actions

This Discussion