Strange IPSEC message on 2821 ISR

Unanswered Question
Jun 11th, 2009

Hi everyone,

I have debug running on IPSec on my router, trying to isolate a tunnel drop problem, and the logs contain many lines with this message:

IPSEC(crypto_get_cm_handle_from_pak): Failed to create access pak subblock

Anyone know what this means? Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
auraza Fri, 06/12/2009 - 18:51

Best to get in touch with TAC for this. They should be able to look it up for you.

What version are you running?

northtexasnetworks Mon, 06/15/2009 - 12:52

Hi Auraza,

I will check with TAC, we are running Ver. 12.4(3f). Is this one know to have bugs?



auraza Mon, 06/15/2009 - 12:57

Mitchell, that is a pretty old version. I would go ahead and upgrade if that is a possibility and see if that fixes the problem for you, in which case it would most likely point to a bug.

zenon_electronics Mon, 09/07/2009 - 22:27

Hi, did you found what is the problem???

I have the same problem since 2 days. Before that everything worked fine!

I don't get any other debug logs from crypto... just this one:

IPSEC(crypto_get_cm_handle_from_pak):Failed to create access pak subblock

Pls help

northtexasnetworks Wed, 09/09/2009 - 09:29

To this day Cisco has not been able to say for sure what causes this message. It may be an IOS bug and it may be a hardware problem. In my situation we had other issues also, such as the VPN tunnel would drop and not come back until we did a reload on the router. I had to replace the router and also update the IOS to a newer release. The new router is running stable however we sometimes still get this error message

zenon_electronics Wed, 09/09/2009 - 23:12

Hi, thanks for your reply. I find where my problem is. I use ADSL connection with ADSL modem in front of my Cisco.

I just restarted my ADSL modem and everything went fine :)


Tihomir Yosifov

IT support


This Discussion