UC520 FXO Disconnect with Arris TM504G

Unanswered Question
Jun 11th, 2009
User Badges:

Hi,


I am having an FXO disconnect problem with an Arris TM504G. Basically I am getting phone through the cable company and the Arris is hooked up to the UC520. I have read the "Understanding FXO Disconnect Problems" document and have tried pretty much everything and none of it has worked. Likewise I have tried the "no battery reversal" keyword as well. I am experiencing the problem from both ends, in that if I call from a cellphone and hangup immediately the IP phones continue to ring, and if I hang up from the IP phone side, it will not disconnect my cellphone. I have also tested the polarity of the lines and they are fine (not sure if this matters). I'm not sure what else to try? Has anyone had experience with Arris and had these problems? Is there some way I can configure the Arris, I tried plugging into the RJ-45 on it (since I have a separate cable modem), but I could not get an IP. Not sure if there is another way to configure the Arris. Here is my config for the voice port section:


voice-port 0/1/0
connection plar opx 600
caller-id enable
!
voice-port 0/1/1
connection plar opx 600
caller-id enable
!
voice-port 0/1/2
connection plar opx 600
caller-id enable
!
voice-port 0/1/3
connection plar opx 400
caller-id enable
!

Any help is appreciated,

Dan
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Trad Thu, 06/11/2009 - 21:15
User Badges:
  • Gold, 750 points or more
  • Cisco Designated VIP,

    2013 Small Business

Hi Dan,


Firstly welcome to the SBCS Forums :) i hope it is of great assistance to you.


Can you try the following code on those voice ports please:


voice-port 0/1/0
trunk-group
translation-profile incoming ADD-0-FOR-REDIAL
supervisory disconnect dualtone mid-call
cptone AU
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx XXX
caller-id enable


There is probably more in there than what you need, but hey if your going to do it, you might as well go the full distance :)



Hope this sorts your problem out, if it doesnt then we will see where to go from there.




Cheers,


David.



[EDIT] Also you can try this as well if the other supervisory disconnect tone command doesnt work.


supervisory disconnect anytone

danielblock1 Fri, 06/12/2009 - 06:57
User Badges:

Hi, thanks for your reply


I have already tried


supervisory disconnect dualtone mid-call
cptone us
timeouts call-disconnect 3
timeouts wait-release 3


and...


supervisory disconnect anytone


Neither of those worked. I assume all of the rest of that stuff (trunk-group, translation-profile, etc..) doesn't matter, if it does, let me know..



-dan

Marcos Hernandez Fri, 06/12/2009 - 08:03
User Badges:
  • Blue, 1500 points or more

We have very little documentation about compatibility with Arris. It seems that "now battery-reversal", "cptone us" and "connection plar opx XXX" have worked for some customers. Nothing else seems to be needed. Remember that you have to issue a "shutdown" then a "no shutdown" for the changed to take. Have you tried contacting your cable provider?


Thanks,


Marcos

danielblock1 Fri, 06/12/2009 - 16:29
User Badges:

So this is really wierd. I realized I wasn't shutting down the ports, so I put the "no battery reversal" in did a shutdown then a no shutdown and it worked for a while. Then all of a sudden it stopped working. The good news at least is that now when I call from my IP phone to my cell and hang up my cellphone does hangup which is better then what it did before. However still when I call from my cell inbound to the IP phones, they keep ringing. Any other ideas? I tried the supervisory disconnect stuff and that did not work.


Secondly, I have not contacted my cable company, however I will on Monday. But assuming they are going to be unhelpful (as I expect them to be), what else can I do. Are there any diagnostics I can run to make this easier to debug? Is there anything else I can try?



Thanks,


Dan

danielblock1 Sat, 06/13/2009 - 11:52
User Badges:

Interesting development.. I hooked an analog phone up to POTS line at home, and called with my cell. When I hangup I hear a click, and the light on the phone temporarily blinks, then there is silence. With the Arris at the site, the light does not blink, there is no click,  and the line goes back to dial tone. Has anybody run into this before? Could the Cisco handle something like this? Otherwise, I guess I will get things started with the cable company (of course they are giving me the run-around).



-dan

Marcos Hernandez Sun, 06/14/2009 - 07:00
User Badges:
  • Blue, 1500 points or more

For the inbound call, do you still have "connection plar opx"?


Marcos

Marcos Hernandez Tue, 06/16/2009 - 11:35
User Badges:
  • Blue, 1500 points or more

Your cable company needs to clarify the technical characteristics of this device, so we can adjust our side accordingly. right now we are guessing and that won't lead us anywhere.


Thanks,


Marcos

danielblock1 Wed, 06/17/2009 - 16:43
User Badges:

Ok, I figured it out. It had to do with an auto-attendant script that I was running (that I forgot about). However, it still rings a few times, after I disconnect. Is this normal behavior? If I have the cable company fix the Arris, so that it functions more like a normal POTS line (instead of the weird dial tone thing), would that fix that problem? Or does it always take a few rings to stop?



Thanks again,


Dan

Marcos Hernandez Wed, 06/17/2009 - 17:29
User Badges:
  • Blue, 1500 points or more

Can you try lowering the "timeouts wait-release" timer under the FXO port? Remember to "shut/no shut" your port after each change.


Thanks,


Marcos

danielblock1 Fri, 06/19/2009 - 13:30
User Badges:

Ok, now I have a related problem. One of my fxo port the 4th one, rings internally, then goes to voicemail after 10 seconds. When I leave a voicemail, it will not release the port. And will just stay connect indefinetly. This is related to my previous problem with the autoattendant, since this is exactly what was happening with that. I just fixed it by bypassing the autoattendant. Why would Unity Express behave differently? It seems as though it is not getting disconnects, once a call has been established. Here is the relevant config...


voice-port 0/1/3
no battery reversal
connection plar opx 400
caller-id enable
!

ephone-dn  30
number 400
label ****
description ****
name ****
call-forward busy 550
call-forward noan 550 timeout 10
corlist outgoing call-***
trunk *100 monitor-port 0/1/3
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
destination-pattern 550
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!

Thanks,
Dan
Marcos Hernandez Mon, 06/22/2009 - 06:07
User Badges:
  • Blue, 1500 points or more

Hi Dan,


The only way to get around this problem is to use tone disconnection. With a Wireshark capture of the whole call, including 5 to 10 seconds of disconnect tones from the Arris device, TAC should be able to help you create a custom CPTONE configuration. My advice is that you get these traces while placing a call to an IP phone and waiting to hear the supervisory signals from the Arris.


You can try creating your own custom cptone by analyzing the traces with a tool like Cooledit (now Adobe Audition).


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Actions

This Discussion