Multicast Problems Between VLANs on 3750

Unanswered Question
Jun 12th, 2009

Multicast Nightmare

Hello, can someone please help me, I have been tearing my hair out with this problem for the last few days without success.

I have a 3750 with IP Services Image. On Monday I will have a phone system on VLAN7 My Voice VLAN that will send multicast traffic that needs to be recevied by an App on some PCs on VLAN3. The 3750 is routing between the VLANs.

As the system is not here I have been testing multicast using VLC which can send and receive from Multicast addresses. Although I can send and receive multicast on the same VLAN as I would expect I cannot get it to work across VLANs using PIM.

I am now totally confused about how it should work. The switch by default has IGMP snooping enabled.

My first question relates to how it should work with just one VLAN. The thing is I dont want that multicast stream broadcast out every port on the switch in the same VLAN as the sender, as the devices on that VLAN do not want to receive the stream, but that is what appears to be happening. A test device on the same VLAN as the stream sender that is not interested in the stream is receiving it, I can see this via tcpdump.

But when I look on the switch it seems to know about where to send the stream...

wd-swh01#sh ip igmp snooping groups

Vlan Group Type Version Port List


7 igmp v2 Gi1/0/47

7 igmp v2 Gi1/0/48 is the stream in question. But I am seeing it on Gi7/0/2 where my tcpdump is running.

Also nothing is recorded in this output:

wd-swh01#sh mac address-table multicast

Vlan Mac Address Type Ports

---- ----------- ---- -----

Is that expected? should that not show the mutlicast address associated to various ports?

Now moving on to try to get the stream to route between VLANs I have enabled pim

Now if move port Gi1/0/47 into VLAN 3, get an IP in the new VLAN, and try to receive the stream from there I cannot.

Please see attaced config and show outputs.

I have tried completely disabling IGMP snooping on the switch to see if that was the problem but it has not helped.

I have learnt about multicast but never used it before so I dont know what to look for.

I have searched many documents without success and I would really appreicate any assistance that anyone can give me.

Thanks is advance


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Harold Ritter Fri, 06/12/2009 - 04:49


For the multicast test between the two vlans, did you set the TTL to something greater than 1.


Harold Ritter Fri, 06/12/2009 - 05:40

Also since you only have one router, you do not really need to run auto-RP. static RP would be far less complicated.

int lo0

ip pim sparse-mode

interface Vlan3

ip pim sparse-mode

interface Vlan7

ip pim sparse-mode

ip pim rp-address


kishan1984 Fri, 06/12/2009 - 04:50

enable multicast routing and then type following command "Switch2(config)#ip igmp snooping querier".it will send the multicast traffic to intersted receivers only.


This Discussion