UCM 6.0 NTP Source

Answered Question
Jun 12th, 2009

I am trying to synchronizing our UCM 6.0 cluster with our LAN NTP source so the PC's & IP Phone's have the same time source. I made the changes at the OS Administration level and rebooted the cluster. 1 pub 2 subs. The pub is pointing to the LAN server and the subs are pointing to the pub. When verifying connection status via CLI I get the following attached message. Any suggestions I can try? Thanks!

Jaime

Attachment: 
I have this problem too.
0 votes
Correct Answer by htluo about 7 years 7 months ago

That's because CUCM only works with NTP v4. Windows NTP only send v3 packets.

Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
rob.huffman Fri, 06/12/2009 - 06:24

Hi Jamie,

It seems like the first reference to 127.127.1.0 means that CUCM is pointing at itself for the NTP setting. Can you try removing 127.127.1.0.

Here is the reference for NTP on CCM 6.x

NTP Servers

Ensure that external NTP server is stratum 9 or higher (1-9). To add, delete, or modify an external NTP server, follow this procedure:

--------------------------------------------------------------------------------

Note You can only configure the NTP server settings on the first node or publisher.

--------------------------------------------------------------------------------

Procedure

--------------------------------------------------------------------------------

Step 1 From the Cisco Unified Communications Operating System Administration window, navigate to Settings>NTP Servers.

The NTP Server Settings window displays.

Step 2 You can add, delete, or modify an NTP server:

•To delete an NTP server, check the check box in front of the appropriate server and click Delete.

•To add an NTP server, click Add, enter the hostname or IP address, and then click Save.

•To modify an NTP server, click the IP address, modify the hostname or IP address, and then click Save.

--------------------------------------------------------------------------------

Note Any change you make to the NTP servers can take up to five minutes to complete. Whenever you make any change to the NTP servers, you must refresh the window to display the correct status.

--------------------------------------------------------------------------------

Step 3 To refresh the NTP Server Settings window and display the correct status, choose Settings>NTP.

--------------------------------------------------------------------------------

Note After deleting, modifying, or adding NTP server, you must restart all the other nodes in the cluster for the changes to take affect.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/cucos/6_0_1/cucos/iptpch4.html#wp1042131

Hope this helps!

Rob

jaimegarcia45 Fri, 06/12/2009 - 06:39

Rob,

How can I remove the 127.127.1.0 source? It is not listed as a source within the NTP servers when I log into the OS Administation page of the pub. The only NTP servers is 172.16.217.242 which I did add. Thanks!

Jaime

Tommer Catlin Fri, 06/12/2009 - 07:39

I never can get CUCM to work with Windows servers, causes nothing but problems for me and keeping time between pubs/subs. So only point to IOS now or a military IP address, forgot the IP off the top of my head

Correct Answer
htluo Fri, 06/12/2009 - 10:16

That's because CUCM only works with NTP v4. Windows NTP only send v3 packets.

Michael

jaimegarcia45 Fri, 06/12/2009 - 10:52

Michael,

Would you recommend pointing CUCM to an external address? Our Wintel Engineer is pointing the PDC to 0.pool.ntp.org (65.255.217.202) and suggested I do the same. Or would I just be better off pointing CUCM to itself? Thanks!

Jaime

Actions

This Discussion