H.323 Gatekeeper on Cisco 2811

Answered Question
Jun 12th, 2009

Hi all,

Would like to know, if it is necessary to upgrade the IOS to the following:


I just want to have the basic gatekeeper features: RAS, CAC and etc.

Really appreciate any kind advice.

Thanks and best regards.

I have this problem too.
0 votes
Correct Answer by Nicholas Matthews about 7 years 4 months ago

You will want to confirm any license purchases after consulting with your local Cisco sales team or partner, but yes, that looks correct.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
boonchin.ng Fri, 06/12/2009 - 08:12

For example, when configuring a Cisco 2811 using the "Cisco Configuration Tool" under the SW Option for 2800 you have the following options:



CISCO IOS Enterprise Base

CISCO IOS Advanced Security


CISCO Advanced IP Services

CISCO IOS Enterprise Services

CISCO IOS Advanced Enterprise Services

Cisco Int Voice/Video: GK, IPIP GW, TDMIP GW

As each SW option has different price tag, so my question is if I select the IOS SP Services for example, do I have the Gatekeeper features? Or I must select the Int Voice/Video: GK, IPIP GW.

I have try searching the feature using the IOS Software Selector and apparently Gatekeeper only available on the Int Voice/Video: GK.

But, I have a 2811 router loaded with c2800nm-ipvoice-mz.124-5b.bin (IOS IP Voice) and I am able to configure the Gatekeeper features.

Thanks and best regards.

Paolo Bevilacqua Fri, 06/12/2009 - 08:42

Some features are really a licensing matter only.

Some, change from version to version.

Some, cannot be understood no matter how much you read and how many you ask.

Basically, if you can have it working, and your cisco rep knows and smiles, you're OK.

boonchin.ng Fri, 06/12/2009 - 08:50

Hi p.bevilacqua,

I got your point. This is also the problem I am facing.

As mentioned, I got Gatekeeper running using IOS IP Voice in my lab router. Hence I quoted my customer the IOS IP Voice for the Gatekeeper. But now my Cisco rep. keep saying I need the Cisco Int Voice/Video: GK

Nicholas Matthews Fri, 06/12/2009 - 09:13

This will work fine until you upgrade to 12.4(20)T or later.

Then, your box will stop functioning after 60 days, and you will need the license for the product to keep functioning.

As long this is a lab router you''ll be OK, but gatekeeper licensing isn't something you want to mess with if you're running production traffic through it.


boonchin.ng Fri, 06/12/2009 - 09:21

Hi Nick,

Thanks for the reply. Just wondering, by any chances you have any document or Cisco link on this Gatekeeper licensing issue?

Really appreciate your feedback.

Thanks and best regards.

Nicholas Matthews Fri, 06/12/2009 - 10:18


Q. I already have a Gatekeeper license running on an older Cisco IOS Software image. Do I have to upgrade my image, or can I continue to use it as is?

A. You do not need to upgrade to the new Cisco IOS Software image (bug fixes, new features, and so on). You can continue using the current image with a purchased feature license. When Cisco IOS Software image upgrades to Release 12.4.15XZ or 12.4.20T are completed, a Gatekeeper license installation will be required to activate the feature on the specific device.


boonchin.ng Sun, 06/14/2009 - 19:09

Hi Nick,

Really appreciate your kind reply.

So in brief, I will need the following to activate the Gatekeeper on top of the necessary IOS version.

FL-INTVVSRV-2811 Cisco 2811 Integrated VoiceVideo License: Gatekeeper IPIP GW

Thanks and best regards.

Correct Answer
Nicholas Matthews Sun, 06/14/2009 - 19:59

You will want to confirm any license purchases after consulting with your local Cisco sales team or partner, but yes, that looks correct.


boonchin.ng Sun, 06/14/2009 - 20:02

Hi Nick,

Thanks for reply. Now at least I have a better picture on the gatekeeper feature license before consulting with my local Cisco representative.


This Discussion