"Database Communication Error" after changing IP address of UCM 7.0.2

Answered Question
Jun 12th, 2009
User Badges:

Getting "database communicaation error" when trying to login to UCM via web after IP address change..We are running Cisco Unified CM Administration System version: 7.0.2.20000-5 ..Pls assist.

Correct Answer by parshah about 8 years 1 month ago

Hi,


Do you know what was on the System > Server page in CCMAdmin before you changed that IP address?


If you have IP address there, than you will need to change the OS IP address back to original one, log into the server and change it in the System > Server page first for all the servers whose IP you will be changing and then change it in the OS.


If you had host name there, than you need to make sure that you have updated the entry for the CUCM servers in the DNS servers and the change has propagated fine.


Thanks,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
parshah Fri, 06/12/2009 - 16:18
User Badges:
  • Cisco Employee,

Hi,


Do you know what was on the System > Server page in CCMAdmin before you changed that IP address?


If you have IP address there, than you will need to change the OS IP address back to original one, log into the server and change it in the System > Server page first for all the servers whose IP you will be changing and then change it in the OS.


If you had host name there, than you need to make sure that you have updated the entry for the CUCM servers in the DNS servers and the change has propagated fine.


Thanks,

allen84us Wed, 07/01/2009 - 20:51
User Badges:

does it mean there is no way for us to change CUCM to new hostname or IP without getting database communication error ?

philippe.cousineau Fri, 08/14/2009 - 05:01
User Badges:

Hi there, I have a similar issue.


I have CUCM 7.0.2a I changed the Hostname using the set network hostname for the publisher, ( I use IP in System/server ) and I change the Set / IP / Publisher on all subscriber but the database is not working anymore. Actually, If I connect to rtmt, it can see the subscribers.

Tommer Catlin Fri, 08/14/2009 - 05:53
User Badges:
  • Green, 3000 points or more

I had an odd issue and i could not get the subscribers to resync the database when I was done with 7.02. I tried every command, every reboot. I ended up upgrading to 7.1.2 and it fixed it. Not exactly sure.


For your example, make sure you did the System server in the GUI FIRST, then do the CLI command to change. If you did it in reverse, the A Cisco DB will not start. You will have to change it back to the original name and IP address, then do it again.

philippe.cousineau Fri, 08/14/2009 - 05:56
User Badges:

ok, super, my problem is same thing but with hostname.... I will let you know


thanks

Tommer Catlin Tue, 08/11/2009 - 07:16
User Badges:
  • Green, 3000 points or more

Many thanks! I had did the following:


Changed IP address in OS

rebooted

Changed hostname

rebooted


Then my A Cisco DB would not start (no login to the GUI). nothing would work.


Changed it back to the original IP address and rebooted.


I could now log in again.

Changed the IP in the System\server first, then the OS

rebooted.


works perfect. THanks the help!!!!

Actions

This Discussion