SPA9000 + Register

Unanswered Question
Jun 14th, 2009

Until now I have only used IP addresses to connect phones to the SPA9000. The SIP URI looks something like this:
<sip:[email protected]> and everything works fine. But I added a DNS server to the network and I wanted to use a URI like this:
<sip:[email protected]>. I entered the proper SRV records to the DNS server and the softphone I am using (Eyebeam 1.5, paid version of X-Lite) does a DNS lookup and sends a register to the correct address 192.168.1.10 and the correct port (6060 in my case). The SPA9000 returns a 404 No Such Name response. Has anyone else had problems registering user phones when a domain name rather than an IP address is used?  Does the SPA9000 require an IP address as the domain name?  I have attached a PDF file showing the SIP trace of a successful and an unsuccessful REGISTER.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Mon, 06/15/2009 - 09:48

Dear Sir;

Thanks for your question. Will escalate (I have not tested this setup before) and let you know.

Regards

Alberto

Patrick Born Mon, 06/15/2009 - 09:52

Hi gzielke,

The SPA9000 does not officially support 3rd-party IP phones, so you're in uncharted territory. :-)

Looking at the trace that you sent, the IP sample attempts to register 192.168.1.11:6060

     Line 1: REGISTER sip:192.168.1.11:6060 SIP/2.0

Looking at the DNS trace you sent, it looks like infotel.local is attempting to register.

     Line 1: REGISTER sip:infotel.local SIP/2.0

Does infotel.local resolve to a valid IP address using either the dig or nslookup utility on a computer?  I would expect to see something like phone1.infotel.local, but I'm no DNS expert.

Using your sniffer, do you see the SPA9000 performing a DNS lookup in order to resolve the infotel.local name in the REGISTER request?

Regards,

Patrick

----------

gzielke Mon, 06/15/2009 - 10:56

Patrick:

Thanks for responding.  I realize that the X-Lite phone is a 3rd party device but when I have used it in the past using IP addresses everything worked as expected.  I have tried using domain names using a software PBX with both the X-Lite and a Linksys SPA94x and they both register OK so I know the DNS part is working.  I was not aware that the SPA9000 did a DNS lookup to resolve the domain name (infotel.local) and I am not sure that this is the way SIP works because I have not seen other SIP PBxs try and resolve the name on REGISTER messages.  However I turned on my analyzer on the DNS server and I saw the X-Lite do a query which returned the correct IP address but the SPA9000 did not do a query.  Unfortunately I do not have a setup that lets me do a trace between a Linksys phone and the SPA9000 to see if something else is going on.  If anyone has a trace of a Linksys phone registering with the SPA9000 using a domain name that would be helpful.

gzielke Mon, 06/15/2009 - 11:24

Further to my original post I came across the following statement in RFC 3261 in section 10.3

A registrar has to know (for example, through configuration) the set of domain(s) for which it maintains bindings.  REGISTER requests MUST
be processed by a registrar in the order that they are received.  REGISTER requests MUST also be processed atomically, meaning that a
particular REGISTER request is either processed completely or not at all.  Each REGISTER message MUST be processed independently of any
other registration or binding changes.

If the above is the case I cannot find where this information would be added in the SPA9000 configuration menus.

gzielke Mon, 06/15/2009 - 13:41

I registered an SPA941 on two different software PBXs using domain names and the registration worked as expected.  Then I changed the DNS entry to point to the SPA9000 instead of the soft PBX and did not change the configuration of the phone.  The phone registered with the SPA9000 but when I looked at the phone's configuration screen the Proxy entry under the Proxy and Registration section had changed from the domain entry "infotel.local." to the IP address "192.168.1.11:6060".  So it appears that the SPA9000 requires an IP address as the domain.  If this is indeed the case it should IMO be documented or corrected to make it compliant with SIP RFC 3261.

Patrick Born Mon, 06/15/2009 - 15:22

Hi gzielke,

This is pretty much what I expected. The SPA IP phones are designed to work with RFC3261-based call control devices while the SPA9000 was designed specifically to support SPA IP phones in a LAN environment.

I checked with Engineering and they confirmed that the SPA9000 only supports registration by IP address.

Regards,

Patrick

----------

Actions

This Discussion