Strange issue moving from VTP client to server

Answered Question
Jun 15th, 2009
User Badges:

Hello.


I need to move a number of switches from VTP client to transparent in an attempt to gain control of my STP domain as the aim is to delete vlans from the switches that are not required.


As I change the first switch to transparent (without deleting any vlans) I loose connectivity to a number of IP phones despite the voice vlan still being listed in the switch running config and 'show vlan'. My phone is connected to the switch in question and although it was not saying 'configuring IP' like the others I could only get intermittent ping responses from the IP.


As soon as the switch is changed back to a VTP client device everything returns to normal.


Any ideas would be much appreciated?


Correct Answer by ivarnhagen about 7 years 9 months ago

Hi!


had a similar issue before. VTP Pruning turned out to be the culprit. Turning it off on the VTP Server solved my problem.


Setup:


SW1(VTPServer)------------SW2(VTPTransparent)-----IPPhone


Somehow, correct me if I'm wrong, the Voice VLAN gets pruned the moment SW2 is changes to transparent mode. SW2 disappears from the VTP Domain, and SW1 (I assume since it isnt getting VTP Messages from SW2) Prunes the VLANs SW2. This is regardless of the VLANs allowed over the trunk and VLANS statically configured on SW2.


This means that traffic to this vlan does not get sent over the trunk to that switch, resulting in your voice VLAN losing connection.


hth

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Marwan ALshawi Mon, 06/15/2009 - 03:06
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

if the vlans were shown in the show vlan and active it should be ok

however try to delet the vlans and recreat them

or when you make it transperant change the VTP domain and bring it back to the original name !!


good luck

Giuseppe Larosa Mon, 06/15/2009 - 03:45
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Richard,

if you want to reduce the number of STP instances running in your switches you don't need to move them to VTP transparent mode.

It is enough to allow on the uplinks only the used Vlans using the command

switchport trunk allowed vlan


where list is made of vlan-ids and vlan-ids ranges with ',' separators without using spaces like:


switchport trunk allowed vlan 1,11,68,69,71,75,85-87,90-93,209,301,401-405,411


the number of vlans advertised by VTP can be greater but number of STP instances is controlled with the above command.

The command has to be given on both sides of each uplink.


Notice that VTP pruning doesn't help in reducing the number of STP instances running.


Hope to help

Giuseppe



vinerichard Mon, 06/15/2009 - 04:07
User Badges:

I am using trunk allowed commands on the uplinks, so this is more of a house keeping task. Strange issue though! I will try and delete the vlan from the switch and recreate out of hours tonight.


Thanks

Correct Answer
ivarnhagen Mon, 06/15/2009 - 06:37
User Badges:

Hi!


had a similar issue before. VTP Pruning turned out to be the culprit. Turning it off on the VTP Server solved my problem.


Setup:


SW1(VTPServer)------------SW2(VTPTransparent)-----IPPhone


Somehow, correct me if I'm wrong, the Voice VLAN gets pruned the moment SW2 is changes to transparent mode. SW2 disappears from the VTP Domain, and SW1 (I assume since it isnt getting VTP Messages from SW2) Prunes the VLANs SW2. This is regardless of the VLANs allowed over the trunk and VLANS statically configured on SW2.


This means that traffic to this vlan does not get sent over the trunk to that switch, resulting in your voice VLAN losing connection.


hth

vinerichard Mon, 06/15/2009 - 07:53
User Badges:

Interesting thought - I have no idea on how this would happen but I do have pruning enabled (even on transparent switches). my understanding was that pruning would be disabled when the switch is changed from server to transparent.


I will aim to disable pruning on the server and all transparent devices before staring my original change.


Thanks for the guidance

ivarnhagen Mon, 06/15/2009 - 08:04
User Badges:

Hi, VTP pruning is usually enabled on the VTP Server for the whole VTP Management domain. It does not need to be enabled on VTP clients or VTP transparent switches.


http://www.cisco.com/en/US/tech/tk389/tk689/technologies_tech_note09186a0080094c52.shtml#vtp_pruning


If you want to continue to use vtp pruning you could try setting the affected VLANs to "pruning-ineligable". I have not done this before but the following syntax might to the trick:


http://cisco.biz/en/US/docs/switches/lan/catalyst2960/software/release/12.2_40_se/configuration/guide/swvlan.html#wpxref73088

Alvaro Garcia Mon, 06/15/2009 - 15:44
User Badges:

It is known that switches in VTP transparent should have VTP pruning disable. Having both features enabled cause connectivity problems with the trunks links to other switches.


I am sure if you disable pruning the issue goes away.

vinerichard Tue, 06/16/2009 - 01:19
User Badges:

Thanks for all your help with this one. pruning has been disabled which means I have changed my devices to transparent without loosing connectivity to my voice vlans.

Actions

This Discussion