Anyconnect: No address assigned

Unanswered Question
Jun 15th, 2009
User Badges:

I am setting up an Any connect SSL VPN on my ASA 5510. I followed this documentation:

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a0080975e83.shtml


I have also created an alias, allowed the users to select this alias and a group url which is accessible.


The problem I am having is when I try to connect it tells me there is: "...security gateway: no assigned address"


Any help?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
auraza Mon, 06/15/2009 - 09:07
User Badges:
  • Cisco Employee,

Do you have an address pool defined under the tunnel-group that you are connecting to?

kyle.southerland Mon, 06/15/2009 - 09:19
User Badges:

Yes. I have a pool specified for the connection profile called:

vpnpool

192.168.10.0/24


I also tried adding it as a network object just in case.

auraza Mon, 06/15/2009 - 09:22
User Badges:
  • Cisco Employee,

Can you post the configuration to the case, or just the output of the following:


show run tunnel-group

show run webvpn

show run group-policy

show run ip local pool


And, the URL that you are connecting to.

kyle.southerland Mon, 06/15/2009 - 10:58
User Badges:

I deleted the connection profile and this time tried adding it through the wizard using the same pool. I then made some changes to that group policy to allow split tunneling. It connects. I am not sure if my split tunneling is working yet, but I will test later tonight. Thank you for your help.

dorkyninja Tue, 05/13/2014 - 15:06
User Badges:

Another reason you may get this is because of the address assignment policy.

If the ASA is set to use an authentication server or an external DHCP then it will fail until you specify one in the connection profile.

The following line fixed this for me by forcing the router to default to a local assignment of addresses for the VPN:

ASA5510(config)# vpn-addr-assign local reuse-delay 5

Hope this helps anyone else that is looking.

 

 

Actions

This Discussion