RVL200 and PPTP passthrough

Unanswered Question

I've configured a VPN on a Windows 2003 server and forwarded port 1723 using the linksys RVL200. There is no option on this router to forward the GRE protocol but PPTP passthrough is enabled.

The VPN hangs on 'verifying user name and password.' I'm pretty sure this is because the router is not passing GRE. I read that this was a problem with older firmware versions but I'm running 1.1.7 which is the current, and only, version available.

I've compared the VPN configuration with other known-good configurations and I'm confident it's not an issue with the VPN configuration. I believe it's an issue with the PPTP passthrough not really working.

Does anyone have any suggestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
dsweeny Fri, 06/19/2009 - 13:17

I see you've port forwarded TCP 1723 to the server, but what about IP protocol 47 (GRE)? Without GRE also being 'port' forwarded to your server, PPTP should not be able to work for inbound connections (WAN to LAN) no matter what router you're using.

The problems with VPN connectivity is not necessarily a matter of TCP/UDP ports being blocked, but possibly lack of support for other IP protocols:

PPTP VPNs require GRE (IP protocol number 47) PPTP also requires TCP port 1723 to manage the GRE tunnel (authentication, etc.).

Well, yes. That's exactly the problem. I've forwarded port 1723 but this router has no option to forward any protocols. It does have an option to allow "PPTP Passthrough" which should pass IP protocol 47 (GRE) but it does not pass the traffic.

Other linksys/cisco options with the PPTP Passthrough option work fine.


This Discussion