6509 rommon recovery

Unanswered Question
Jun 15th, 2009

My CatOS image got corrpupted and now I'm trying to boot off the flash card but after I specify the location of the image..it decompresses but gets stuck at boot slot0:.....bin

I've tried putting a new image on the flash card but it doesnt work..I would appreciate any help on this..Thanks..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sudheesh.pb Mon, 06/15/2009 - 11:02

Pls check the flash got currupted or not.. you can try one option, reboot the system and get in to rommon, and try the command, tftpdnld -r, after providing the IP ADDRESS , MASK, GATEWAY, FILE, parameters.(please check on cisco, for this command details) This will copy the image from the tftp, and will not try to save on Flash. If this is working, you can confirm that there is an issue with your flash.

Thanks,

Sudheesh

uzmausmani Mon, 06/15/2009 - 11:27

The tftpdnld command does not work...it says "command not found". I specified all the other parameters already. I googled but didnt find anything for this. You might be right that the flash has a problem but I tried to xmodem but that didnt work either..Is there any other way to do this?

uzmausmani Mon, 06/15/2009 - 11:49

I used that same document to set the IP on it. But my switch does not like the tftpdnld command for some reason.. Yes it is an external flash card. I've tried reseating it many times. It decompresses the images..checks all systems but then gets stuck at the same place everytime

"Boot image: slot0:cat6000-supk9.7-6-24a.bin"

kishan1984 Mon, 06/15/2009 - 22:53

just format the flash in rommon mode and then use xmodem(choose send file option) and ensure that no firewall is open in ur desktop.it is stucking because of flash problem once u format it,it should go smoothly.

uzmausmani Mon, 07/06/2009 - 06:13

I formatted the flash drive and reloaded all the images onto it via another device. I thought perhaps the switch is having memory issues. I used another image with lower memory requirements but it didnt help. Its still stuck at the same spot ("autoboot image: ") I've tried xmodem but that doesnt go anywhere. I'm slowly running out of options here..

Actions

This Discussion