Not discovering End devices on some 4503 switches

Unanswered Question
Jun 15th, 2009
User Badges:

I run LMS 2.6. I am having an issue with end devices on some 4503's not being discovered. My 4506's run the same IOS and the same configuration and are listing all end devices. I checked cdp in the switches and all see their neighbors, but in Device manager in LMS, the cdp neighbor is blank. I checked snmp etc. Everything else in LMS is populating for these switches, just not end devices. I've run Data Collection few times. Still nothing.

Any suggestions or help would be appreciaed.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 06/15/2009 - 12:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Exactly what version of Campus Manager do you have? What version of IOS is running on these switches?

kris55s Mon, 06/15/2009 - 12:47
User Badges:

I'm at home right now. I'll have to get that info tomorrow.

kris55s Tue, 06/16/2009 - 03:39
User Badges:

Campus Manager 4.0.12


IOS 12.2(31) SGA9

Joe Clarke Tue, 06/16/2009 - 08:56
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

As far as I can tell, all models of 4503 are supported in this version of Campus. Make sure that these switches have been Data Collected. Check that you do not have any Data Collection filters defined in Campus, then run a full Data Collection from the Campus Manager homepage.


When Data Collection finishes, check the topology map to see how these switches appear.

kris55s Tue, 06/16/2009 - 09:32
User Badges:

I ran Data Collection a few times. Checked the Data Collection filters, have none defined. Switches look fine in topology and in Cisco View.


In the Data Collection details, I have a few that are not showing any cdp neighbors. And those are the ones that will not show any end devices when I try to run a UT report. If I telnet into these switches and do a sh cdp neighbor, the neighbors are there.


Anything else I can check?

Joe Clarke Tue, 06/16/2009 - 09:34
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

If they show up fine in Topology, then they should have neighbors. Post a screenshot showing one of these 4503s on the Topology Map.

kris55s Tue, 06/16/2009 - 10:05
User Badges:

I just went back into Topology after doing another Data Collection and now they are not showing up.


*sigh*

Joe Clarke Tue, 06/16/2009 - 10:19
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Then that explains all the other problems. You can check the ani.log for errors pertaining to these devices. The most likely cause is bad SNMP community strings.

kris55s Tue, 06/16/2009 - 10:57
User Badges:

That seems to be the problem. The RW snmp is there and I did an edit device credentials, but when I do a credential verification report, under the Read Write Community column it comes up "No Value to test". RW configured on switch the same as the others that I'm not having any issues with, and in Ciscoworks the same.


BUT, another switch that I am having the same issue with, both Read and Read/Write Community when I do a Device Cred. verification come up "ok".

Joe Clarke Tue, 06/16/2009 - 11:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The read-write community string is not required for Data Collection. As long as you have a valid read-only string, Campus should be able to manage the device. Again, the ani.log may have more details if there is an error trying to communicate with these devices.

kris55s Tue, 06/16/2009 - 11:22
User Badges:

Nothing in the ani.log for the switches that I am having this issue with.

Joe Clarke Tue, 06/16/2009 - 12:06
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Check the Unconnected devices view in Topology Services. Do these switches show up there.

kris55s Wed, 06/17/2009 - 04:21
User Badges:

No, but other switches do. They all show as reachable with cdp neighbors.

Joe Clarke Wed, 06/17/2009 - 08:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Go ahead and open a TAC service request for this. They will walk you through enabling debugging so that further analysis can be done.

kris55s Wed, 06/17/2009 - 08:45
User Badges:

Thanks for your help. I'll open a TAC.

Actions

This Discussion