Convert Progress to Disconnect ISDN Q931 Message

Unanswered Question
Jun 16th, 2009
User Badges:

Hi,


currently I have a problem with my QSIG ECMA CUCM <-> siemens connection.


PSTN E1 PRI<->H323<->CUCM<->MGCP QSIG ECMA E1 PRI<->SIEMENS


the siemens is not delievering a disconnect code, instead it delivers a progress message with the following q931 debug:


Jun 16 15:38:46.460: ISDN Se0/1/1:15 Q931: RX <- PROGRESS pd = 8 callref = 0xBC34

Cause i = 0x8091 - User busy


disc-pi-off is for sure not the problem, because I tried all possible configurations. The CUCM service parameter does now state the following:


Convert Progress to Disconnect for User Side PRI EURO: This parameter determines whether to convert a Progress request that contains a Call Clearing cause value to a Disconnect message. Valid values specify True (convert the Progress request to a Disconnect message) or False (do not convert the Progress request). This parameter is only applicable to the USER side of a PRI EURO interface during the call establishment phase.


But this seems not to work, is this because I have a QISG. Does this paramter need a CUCM restart? I have alredy done a mgcp reset (no mgcp/mgcp). Has anyone a clue, what else could help? The problem is, that the caller hers ringback all the time. Would it be possible to play busy back instead of ringback in that case?


Currently I'm also not sure if the Siemens could be reconfigured so that it sends a disconnect.


any idea is very much appreciated


Cheers

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
paolo bevilacqua Tue, 06/16/2009 - 14:51
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes, whatever setting you do at gateway level does not matter, because you are using mgcp.


I think if you were to use h.323, gw would open audio path and caller would get busy tone.


PBX is right in not sending a disconnect.

c.hennrich Tue, 06/16/2009 - 15:04
User Badges:

thanks for your reply.


I cannot use H323, because only mgcp supports the full QSIG feature set.


I have also studied the ITU Q931 documents, the progress is ok, but with Cisco it does not work in they way we need it. So therefore I would like to transform the progress to disconnect from cucm side. Therefore I activated the mentioned CUCM service paramter, but with no luck.


The progress message is also not forwarded correctly. probably the command: voice rtp send-recv could help, to play busy.


cheers

paolo bevilacqua Tue, 06/16/2009 - 15:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I wouldn't be sure that only mgcp supports full qsig, check documentation for the specific feature you're interested in.


Again, no gw level command will help, because with mgcp the router becomes stupid. Problem is, sometime cucm is stupidest, so better stick with h.323.

Nicholas Matthews Tue, 06/16/2009 - 18:44
User Badges:
  • Red, 2250 points or more

This service parameter was added specifically for this purpose. This isn't something I can recreate in the lab, so I would play with it more.


For reference, this was created via this bug: CSCsb92313



Possibly set the MGCP gateway switch type for PRI EURO but the isdn switch type on the PRI itself to QSIG.




-nick

c.hennrich Tue, 06/16/2009 - 23:15
User Badges:

Thanks for your answer. This might help. In the Bug description is this note, do you know what to do additionally?


Additional Info:

As part of the fix, a new service parameter was added called "convert Progress to disconnect";on enabling which the conversion takes place from Progress to Disconnect. But the defect was reopened as the service parameter was not functioning and so there was an additional fix put in Feb'2009 which is required for the service parameter to work.




Regards

Francisco Lucen... Wed, 06/17/2009 - 03:35
User Badges:

Hi!! I have the same problem, but where I can find this pix that was put in Feb'2009? I need this fix for the service parameter to work..


Thanks!!!


Fran

Nicholas Matthews Wed, 06/17/2009 - 04:48
User Badges:
  • Red, 2250 points or more

Hi,


This is referring to an internal fix where this service parameter wasn't acting correctly. If it is not working correctly for you I would check your CUCM version against the fixed-in field of the bug, to make sure you have a version that has the true fix.




hth,

nick

c.hennrich Wed, 06/17/2009 - 04:55
User Badges:

does the activation of the feature need a cucm service restart? I have not doen a restart, so that might be the problem, but currently I cannot simply restart.



Nicholas Matthews Wed, 06/17/2009 - 06:21
User Badges:
  • Red, 2250 points or more

If the description doesn't say a restart is needed, you shouldn't need to restart. I would still reset the MGCP gateway for good measure, however.



-nick

Francisco Lucen... Thu, 06/18/2009 - 23:36
User Badges:

I restart the server with the new configuration but it doesn't work fine. I have the same problem.


Fran

c.hennrich Thu, 06/18/2009 - 23:38
User Badges:

I have a TAC open, I will let you know about the answer from Cisco.

c.hennrich Fri, 07/03/2009 - 07:28
User Badges:

Cisco TAC told me that the update/upgrades to the following versions help:


TAC:

spoke with cust,

- told him that they are indeed hitting this bug and they need to upgrade the CUCM to any of the following version:

7.0(1.21022.1)

7.0(2.11004.1)

7.1(1.39000.60)

7.1(2.10000.16)

Francisco Lucen... Fri, 08/14/2009 - 02:50
User Badges:

I upgrade to this version but I have the same problem yet.


Do you have any ideas?


Fran.

paolo bevilacqua Fri, 08/14/2009 - 03:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

It's H.323 or SIP time perhaps ?



Francisco Lucen... Fri, 08/14/2009 - 05:03
User Badges:

I'm trying with H323, but I need to setup it on my CUCM with the parameter "tunneled protocol QSIG" to communicate with my gateway (because I need features Call Completion CCBS/CCNR)but I cannot make any call with tunneled QSIG,also without tunneled QSIG I can do calls ok.

I don't know if I need any change on my dial-peer voice voip that I have on my gateway configuration to it working fine.


Topology:


CUCM---H323(TUNNELED PROTOCOL QSIG)--GW2811---E1(PRI QSIG)----PBX


Do you have any tunneled protocol qsig configuration on a h323 gateway?

paolo bevilacqua Fri, 08/14/2009 - 06:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Just to bring more wood to the fire.


There was also a quite recent thread about an ISR GW not relaying correctly the Busy PI using SIP. Basically Cisco did not even wanted to admit that was wrong, although it was proven that AS5x00 series GW do correctly convey the PI with the same identical configuration.


Seems like dealing with such a basic matter is too difficult for Cisco ?!?

Francisco Lucen... Sun, 08/16/2009 - 05:56
User Badges:

Ok Thanks Paolo!


But how can I configure my H323 gateway with QSIG tunneling to communicate with my CUCM?

I set the CUCM -> H323 Gateway -> Tunneled Protocol -> QSIG, the question is .. What I have to configure the gateway for communication with CUCM work properly?

Without Tunneled Protocol -> QSIG configured in CUCM calls are made perfectly but with Tunneled Protocol -> QSIG can not make calls.

Is there any sample configuration for configuring the H323 gateway?

Francisco Lucen... Thu, 06/18/2009 - 23:39
User Badges:

I restart the server with the new configuration but it doesn't work fine. I have the same problem.


Fran

Keith Fulcher Mon, 08/09/2010 - 02:52
User Badges:

Any new status to this? I appear to have run into the same problem.

Actions

This Discussion