How do I inject a static default route into vrf

Answered Question
Jun 17th, 2009
User Badges:

Could anybody give me any advise on injecting a static default route into vrf.


The static route is to the internet, I can't enable vrf forwading on the fa interface as other users also use this internet connection.


I am configuring a 7206 VXR 12.3(26) and have attached a copy of the config


Any help gratefully received



Attachment: 
Correct Answer by mlund about 7 years 11 months ago

Hi


I think you have to specify the route as this

ip route vrf delegate_wireless fa0/0 0.0.0.0 0.0.0.0 194.154.168.1 global

it tells the router to to use a next hop that is not part of the vrf.

Also, don't forget that the return traffic has to be routed out to the vrf.

Something like this.

ip route a.b.c.d tu1 10.252.254.2


/Mikael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
m-bosch Wed, 06/17/2009 - 00:44
User Badges:

You have the correct syntax ie “ip route vrf (vrf name) 0.0.0.0 0.0.0.0 (internet router / address)”


I don't suppose you running any sort of dynamic routing?

anne-mariecrampton Wed, 06/17/2009 - 01:06
User Badges:

Hi


We're not running on dynamic routing on this particular router.


The static route I've configured doesn't show up in the vrf routing table, do you think its because I don't have VRF forwarding enabled on the internet fa interface (which I can't do as other non vrf networks use this aswell)


Thanks for your help

m-bosch Wed, 06/17/2009 - 01:24
User Badges:

What does "sh ip route vrf (vrf name)" show?


Does you internet router participate in the same vrf?



anne-mariecrampton Wed, 06/17/2009 - 01:36
User Badges:

Hi


Sh ip route vrf (vrf name) just shows the eigrp routes, the vrf static route is not visible


The internet router doesn't participate in any vrf. I'm trying to get the traffic to 'leave' the vrf and route it to the internet.

Thanks for your help

Correct Answer
mlund Thu, 06/18/2009 - 05:32
User Badges:
  • Silver, 250 points or more

Hi


I think you have to specify the route as this

ip route vrf delegate_wireless fa0/0 0.0.0.0 0.0.0.0 194.154.168.1 global

it tells the router to to use a next hop that is not part of the vrf.

Also, don't forget that the return traffic has to be routed out to the vrf.

Something like this.

ip route a.b.c.d tu1 10.252.254.2


/Mikael

m-bosch Thu, 06/18/2009 - 06:45
User Badges:

Mikael, must say i did not even think of the tunnel ;o)


I would have just setup bgp between the 2 with "default-originate" on the internet router.

thoughtjj Thu, 06/18/2009 - 08:41
User Badges:

HI


what mean of tu1 in the vrf

ip route a.b.c.d tu1 10.252.254.2

e.g

interface gi1/0.100

ip vrf forwarding access-to-internet

ip add 10.252.254.2 255.255.255.252


how can i set a static route in this case for the traffic which is return from the internet?


thanks!

anne-mariecrampton Mon, 06/22/2009 - 00:37
User Badges:

Hi Mikael


Thank you so much much for your help, your suggestion worked a treat!


Kind regards


Anne-marie

Actions

This Discussion