CISCO phones releasing IP addresses

Unanswered Question
Jun 17th, 2009

Hi there,

I have got a situation when some of my phones constantly realising IP settings and trying to get a new ones.

I am using CCME 7.1, 2 Windows DHCP servers with a few scopes.

I have got 2 DHCP server server1(win2k3 sp2) and server2(win2k3 sp2) in the single domain which are on the different subnets.

It created a Spitted scope

server1 address pool: for distribution -, excluded -

reservation for hp switch 000d9db48500

server2 address pool: for distribution -, excluded -

reservation for hp switch 000d9db48500

Router Cisco 2821. HP switch connected to the Cisco router also I am using POWERDsine 6024 switch, also I have got 3 VLANS.

It looks like HP switch or Cisco router is trying to change a vlan once per minute.

Cisco phone connects to hp switch which is connected to cisco router, on cisco router there is a dhcp relay set up.

This phone is constantly releasing ip settings.

I checked logs on server1 and server2.














24,06/10/09,11:15:24,Database Cleanup Begin,,,,

25,06/10/09,11:15:24,0 leases expired and 0 leases deleted,,,,

25,06/10/09,11:15:24,0 leases expired and 0 leases deleted,,,,








Any advices how to resolve this problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Wed, 06/17/2009 - 04:18

Do not use any server for dhcp to the phones.

Put the phones in voice vlan and let cme router be dhcp server, with default settings and option 150.

You will never have any problems doing so "by the book".

vasily.kravchen... Wed, 06/17/2009 - 04:28

I have got a separate voice vlan, using 10.110.64.x/24(for data), 10.110.0.x/23(for data),10.111.0.x/23(for voice).

It is required to use windows dhcp servers.

Paolo Bevilacqua Wed, 06/17/2009 - 04:32

Required by who?

Cisco phones work well with cisco router dhcp server (or CUCM), that is what cisco tells you to do and everybody does, once you deviate from that you're on your own.

Paolo Bevilacqua Wed, 06/17/2009 - 04:48

You should work on improving policies instead.

"company" should have no word on technical matters and the best way to make things work.

vasily.kravchen... Wed, 06/17/2009 - 06:41

I don't want to be rude,

but you don't need to comment if you are not able to offer particular solution for particular task.

I don't want to participate in the dispute like what is better windows or linux.

vasily.kravchen... Wed, 06/17/2009 - 06:42

I don't want to be rude,

but you don't need to comment if you are not able to offer particular solution for particular task.

I don't want to participate in the dispute like what is better windows or linux.

Nicholas Matthews Wed, 06/17/2009 - 06:47

Hi Vasily,

There are some things to look into:

Check the lease time on the phones. Most DHCP servers have the renew time to half the lease, and the phones will follow this.

You may also want to do some search for HP compatibility with IP phones. The phones normally get their VLAN ID via CDP, which the switches may be 'faking' or be related to the problem.


ivarnhagen Wed, 06/17/2009 - 07:16


to add to Nicks post, here is an interoperability guide for Cisco IP Phones with HP Switches. I had this set up in a lab and it seemed to work reliably.

7900 Phones with newer firmware (as of 8.3(3))use LLDP to negotiate Voice VLAN with HP Switches.

Also you could check to see if there is a new firmware version for your phones.


Paolo Bevilacqua Wed, 06/17/2009 - 10:11

No dispute here.

Cisco makes a product and tells you how to configure it (best practices).

In the DHCP case, that is because no matter what, the phone system never depends by an external server, even if redundant. As you gain experience, you will find that this a very good thing.

When you deviate from best practices, you're on your own, good luck.

Stoyan Stoitsev Wed, 06/17/2009 - 23:02

Hi Vasily,

I think the phones are getting confused which server to ask for addresses.

Can you show us your ip helper config?

Can you try using just one server for the config as a beginning so we can separate the possible causes - dhcp problem or phone fw problem.

DHCP is a standard protocol so it should work no matter if on server or on any other device.

Justin Brenton Thu, 06/18/2009 - 00:42

I agree with Vasily, Use 1 DHCP server per vlan, DHCP requests will be sent to any server it hits first...

That and increase your DHCP lease time on your voice vlan.

Do you have a ip helper-address assigned on the HP Switch for the voice vlan?

HTH, Please rate if so



Paolo Bevilacqua Thu, 06/18/2009 - 00:50

Then what happens if you have a power glitch and the windows servers says "no active partition found" when rebooting ?

vasily.kravchen... Thu, 06/18/2009 - 02:42

Now I have done an experiment.

I have got a spare power adapter for my test phone.

Plugging my test socket directly into the cisco 2823.

Now I have got a permanent IP address on my phone from windows server. It is IP address.


cisco config

vlan 1

description Clients1

ip address

ip helper-address

ip helper-address

no mop enabled

vlan 2

description Voice-Clients1

ip address

ip helper-address

ip helper-address

vlan 3

description Clients2

ip address

ip helper-address

ip helper-address

interface FA 1/3

description test-phone

switchport trunk allowed vlan 1,2,3,…

switchport mode trunk

switchport voice vlan 2

Phone is getting Operational VLAN id 2(when It is plugging in into hp switch where we have the problem this field is empty, if I plug it into different hp switch it is getting vlan).

We have got many hp switches and have this problem only with one of them.

So it looks like problem connected with wrong hp switch configuration.

ivarnhagen Thu, 06/18/2009 - 03:24

Hi Vasily,

If you have this problem with only one HP switch, compare the firmware versions and switch configuration. If necessary, upgrade the firmware of the HP switch.

You should also check speed/duplex settings ony your switch. E.g. the powerdsine you mentioned only supports 10/100, no gigabit. Only the powerdsine 6024G supports gigabit. so if your HP switch is gigabit, set it to 100Mbit/Full manually just to be one the safe side.



vasily.kravchen... Thu, 06/18/2009 - 04:24

Now I am using a power adapter instead of power switch just for test phone.

2 hp switches 2650, the same firmware, they are behaving differently. I am trying to find out difference in configs.

vasily.kravchen... Thu, 06/18/2009 - 08:00

Not working hp switch had next setting for the phone's port

Vlan1, Vlan2, Vlan3

Tagged Tagged Untagged

On working switch it is

Vlan1, Vlan2, Vlan3

Untagged Tagged No

After I change particular port on switch 1 to

On working switch it is

Vlan1, Vlan2, Vlan3

Untagged Tagged No

and restarted port

phone started work properly and showing operational vlan 2

now I need to spend some time in order to investigate how to set up vlans configuration for ports properly.


This Discussion