Voice class codec command not working right

Unanswered Question
Jun 17th, 2009
User Badges:

Hello,


I am using the following on my inbound dial-peers:

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

Inbound calls all come in at g711ulaw. If I remove the codec pref 2 g711ulaw command, then calls come in g729 as both are advertised by the provider, global crossing, g729 first, then g711 second. Appears to be a bug or am I missing something?? Why aren't the calls connecting at g729r8 as that is my first preference??


Thanks,

Chuck

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Wed, 06/17/2009 - 06:07
User Badges:
  • Red, 2250 points or more

Hi Chuck,


Your preferences will not always be the first choice, depending on how the negotiation is done. It's also possible that you're using something like G729br8 and the provider is looking for G729r8.


This is likely something you can solve by talking with your provider, because if you're sure that voice class codec is applied to the right incoming dial peer, that is all you can do.



-nick

Chuck Reid Wed, 06/17/2009 - 06:11
User Badges:

Hello,


I verified with provider that g729r8 is correct, I am thinking that this may a SIP Issue, this is a cube router, sip-sip, and when i do a debug ccsip all I see that :


Static payload sets g711ulaw

Preferred codec is g729r8

Dynamic payload(100) could not be reserved.


I'm thinking i need to do something with sip command to be able to choose the codec?


Chuck


Nicholas Matthews Wed, 06/17/2009 - 06:23
User Badges:
  • Red, 2250 points or more

Hi Chuck,


That output looks normal. You may want to use 'rtp payload nte 100' on your dial peers to prevent that last line, but so far that looks alright.


If you're using voice class codecs and CUBE, make sure you have the same one on the incoming and outgoing dial peers.


-nick

Chuck Reid Wed, 06/17/2009 - 06:26
User Badges:

Hi, yeah, I have the payload type set already for nte 100, cant figure out why its not taking g729r8. It only takes g729 if I remove the option for G711.

Nicholas Matthews Wed, 06/17/2009 - 06:31
User Badges:
  • Red, 2250 points or more

Hi Chuck,


It sounds like the provider prefers G711, so that's what they're choosing.


They send the INVITE with their capabilities. We send a 200 OK with our preferences. They choose which of our preferences they want to use.


-nick

Chuck Reid Wed, 06/17/2009 - 09:06
User Badges:

Hi Nick,


I emailed you a debug trace, didnt want to post it to the world, if you can take a quick look, Id appreciate it, the provider said they offering g729 first, then g711 second.



Thanks,

Chuck

Actions

This Discussion