Problems installing device packages in RME 4.0.6

Unanswered Question
Jun 17th, 2009
User Badges:

I am trying to install device packages into RME 4.0.6 and running into dependency problems I can't resolve. For example, the Readme file for LibSwim.RME40.v1-8-7.zip states that the software dependency is RME 4.0.6 and MDF 1.25 and the only package dependency is LibCommon.RME40.v1-3-5.zip.


RME 4.0.6 is installed.

<NMSROOT>\lib\classpath\com\cisco\nm\cwcs\mdf\mdfdata.xml claims to be "version : 1.26 (001) Last Modified on mm-dd-yy:03-31-09 ". However, I see references to V1.27 being installed in the PSU.log

The CS device update package map states that LibCommon is at version 1.3.5


If I attempt to install LibSwim from the command line this is what I get:


C:\LMS Patches\RME\Device Updates>"\program files\cscopx\bin\psucli" -p rme -ins

tall -src . LibSwim

Services might be restarted, as a result of install operation

Would you like to continue ? ( Press y or n )

y

Proceeding with install..

Loaded psu.properties..

INFO: Installing for rme

Locking the package repository...

got all packages Repository

Checking Dependencies...

WARNING: LibSwim(1.8.7):Consistency check failed for base package SharedSwimOpti

calSwitch

There are no Packages to be installed

Released the Lock...

No package(s) to install for Resource Manager Essentials


So where does SharedSwimOptialSwitch come from? I don't see a package for it anywyere.


The psu.log file is attached.




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Stanford Wed, 06/17/2009 - 08:32
User Badges:
  • Cisco Employee,

What version of LibSwim do you currently have installed

?

David Stanford Thu, 06/18/2009 - 08:25
User Badges:
  • Cisco Employee,

You need to update your LibSwim to 1.8.7 to resolve this error.

jedavis Thu, 06/18/2009 - 09:15
User Badges:

That is what I am trying to do - update LibSwim to 1.8.7. If you look at the output of the psucli command in my original post you will see that it won't install because of a dependency on SharedSwimOpticalSwitch.

richard.tetu Tue, 07/28/2009 - 01:23
User Badges:

Hello Dears,

I have the same problem with RME 4.0.6.

The packages has been pushed from the download site of RME.

I have read the dependancies of the packages which should be installed and i have respect the installation sequence.

....


Martin Ermel Tue, 07/28/2009 - 05:16
User Badges:
  • Blue, 1500 points or more

what are your temp and tmp variable settings?

Login to your windows mashine then issue the DOS "set" command and post the output.

jedavis Tue, 07/28/2009 - 11:43
User Badges:

I discovered that the SharedSwimOpticalSwitch package is not installed as an independent package, but is installed along with one of the CW apps. I can't remember which one, my guess is Common Services. You need the latest CS version which is 3.0.6 under LMS 2.6.

richard.tetu Tue, 09/01/2009 - 06:39
User Badges:

Hello, dears all,


I afford to enter on this thread with my temp and tmp values given by the command set.

Microsoft Windows [Version 5.2.3790]

(C) Copyright 1985-2003 Microsoft Corp.


C:\Documents and Settings\Administrateur>set

AdminEmail=[email protected]

ALLUSERSPROFILE=C:\Documents and Settings\All Users

APPDATA=C:\Documents and Settings\Administrateur\Application Data

CLIENTNAME=EXBG02G

ClusterLog=C:\WINDOWS\Cluster\cluster.log

CommonProgramFiles=C:\Program Files\Common Files

COMPUTERNAME=SPMLBFRLMS01

ComSpec=C:\WINDOWS\system32\cmd.exe

CWMIBDIR=d:\cwlms\objects\share\mibs

FP_NO_HOST_CHECK=NO

HOMEDRIVE=C:

HOMEPATH=\Documents and Settings\Administrateur

LDMS_LOCAL_DIR=C:\Program Files\LANDesk\LDClient\Data

LM_LICENSE_FILE=d:\cwlms\objects\smarts\conf\trial.dat.DFM

LOGONSERVER=\\SBDADC1

NUMBER_OF_PROCESSORS=2

OS=Windows_NT

Path=d:\cwlms\campus\bin;d:\cwlms\objects\smarts\lib;d:\cwlms\objects\smarts\bin;d:\cwlms\MDC\tomcat\bin;d:\cwlms\MDC\Apache;d:\cw

lms\MDC\jre\bin;d:\cwlms\MDC\bin;d:\cwlms\lib\jre\bin\server;d:\cwlms\objects\db\win32;d:\cwlms\bin;C:\WINDOWS\system32;C:\WINDOWS

;C:\WINDOWS\System32\Wbem;C:\WINDOWS\system32\WindowsPowerShell\v1.0;

PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.PSC1

PROCESSOR_ARCHITECTURE=x86

PROCESSOR_IDENTIFIER=x86 Family 15 Model 4 Stepping 1, GenuineIntel

PROCESSOR_LEVEL=15

PROCESSOR_REVISION=0401

ProgramFiles=C:\Program Files

PROMPT=$P$G

SESSIONNAME=RDP-Tcp#3

SM_BROKER=spmlbfrlms01:9002

SM_HOME=d:\cwlms\objects\smarts

SM_RULESET_PATH=d:\cwlms\objects\smarts\rules

SM_SITEMOD=d:\cwlms\objects\smarts\local;d:\cwlms\objects\smarts

SM_SNMP_BUG_COMPATIBLE=1

SystemDrive=C:

SystemRoot=C:\WINDOWS

TEMP=C:\DOCUME~1\ADMINI~2\LOCALS~1\Temp\1

TMP=C:\DOCUME~1\ADMINI~2\LOCALS~1\Temp\1

USERDNSDOMAIN=FR.SUB

USERDOMAIN=ZF

USERNAME=Administrateur

USERPROFILE=C:\Documents and Settings\Administrateur

windir=C:\WINDOWS


Thanks by advance.

Actions

This Discussion