Etherchannel - err disabled

Answered Question
Jun 17th, 2009

Hello, I'm practicing forming Etherchannel groups and I have a question. I have two switches with Fa 0/5, 6 ,7 as trunks between the switches. When create the Po1 adding each interface one by one (first in one SW and then in the other SW) my Po1 goes to an err-disabled status in the first SW. Then I have to enter into the Po1 interface, apply a shutdown and then a no shutdown and then the Po1 comes up........ is this a normal behavior when you add each interface one by one to the Po? .... see the attachment.

When I create the Po1 by adding the 3 interfaces together (int range fa 0/5 - 7) in one SW the interfaces go down. Then I do the same in the other SW and once the Po1 has been configured in both SWs the Po1 comes up by itself I dont have to apply a shu/no shut to the Po1 interface.

Is there a way to create a Po without interrupting traffic? What is the normal or best way to create the Po?

Attachment: 
I have this problem too.
0 votes
Correct Answer by thotsaphon about 7 years 7 months ago

Francisco, Hi It's me again!

I'd recommend you to do as follows:

- Shut all interfaces in the channel down on both sides. To avoid the order operation problems.

- start configuring Etherchannel all interfaces.

- Make sure that all interfaces have identical configuration.

- Bring all interfaces back up.

You can use a "show interface status err-disabled" command to see what's the problem.

Hopes this link can help you some:

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00806cd87b.shtml

HTH,

Toshi

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Correct Answer
thotsaphon Wed, 06/17/2009 - 13:10

Francisco, Hi It's me again!

I'd recommend you to do as follows:

- Shut all interfaces in the channel down on both sides. To avoid the order operation problems.

- start configuring Etherchannel all interfaces.

- Make sure that all interfaces have identical configuration.

- Bring all interfaces back up.

You can use a "show interface status err-disabled" command to see what's the problem.

Hopes this link can help you some:

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00806cd87b.shtml

HTH,

Toshi

glen.grant Fri, 06/19/2009 - 08:25

That is normal behavior . When creating etherchannels particularly negotiated ones such as LACP or PAGP all ports have to be brought up at the same time via the port channel interface , not the individual interfaces in the group.

Actions

This Discussion