Fax Problems FXS port UC520

Unanswered Question
Jun 18th, 2009

We are having problems with outbound faxes with a fax machine connected to FXS port of a UC520.

Outbound faxes are received on the receiving machine as "half pages". Inbound faxes are received correctly.

We have replaced cables and tried with 3 different fax machines but the problem stays the same. We allso checked the configuration for network-clock settings but this settings are ok.


network-clock-participate wic 1

network-clock-select 1 BRI0/1/0


When the system is rebooted, all fax sending/receving works fine for a while, but the problem keeps recurring after a few hours.

I don't know where to search further for a solution on this.

Any help would be greatly appreciated!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nicholas Matthews Thu, 06/18/2009 - 15:50

Generally, if you have pots-pots, which I'm guessing you do in this case since it is FXS to BRI, the router doesn't do much in terms of faxing.

A few things you can try:

voice-port 0/2/0

input gain -3

output attenuation 5

voice service voip

modem passthrough nse codec g711ulaw

Check for slips on your BRI port, or any other line error.

You may also want to upgrade your IOS to something like 12.4(24)T. I have seen a few cases where the intermittent faxing problems have been solved with an IOS upgrade to this version.



TrustIT-Spiere Fri, 06/19/2009 - 04:42

Hi, thanks for your reply.

Correct, it's FXS to BRI. We have used three fax machines to test the issue, the original fax is a Brother MFC8860, but we allso tested with a older (slower fax speed) machine, which resulted in the same "half page" problem.

I have now added the "modem passthrough nse codec g711ulaw" command.

I will contact our client in a few days to see if the issue is solved by then, if not i will add the "input gain -3" and the "output attenuation 5" commandos.

The IOS version now used is 12.4(11)XW7

If u want I can attach my show tech to this topic.

TrustIT-Spiere Mon, 07/13/2009 - 00:02

Hi Nick,

I have changed all the settings you gave in your last post.

input gain -3

output attenuation 5

I have allso upgraded the IOS to 12.4(24)T and the outgoing fax problem is solved. but now a incoming fax problem is created :) a lot of incoming faxes give a error report on the sending side so that the sending side keeps on resending the fax. Resulting in a lot of the same faxes on our faxing machine.

could it be that this is something with any kind of signaling that isn't terminated correctly, or does this echo settings are bit to strong?

Many thanks in advance,


Nicholas Matthews Mon, 07/13/2009 - 10:17

Hi Peter,

Generally fax problems like this require much more information like packet captures and to listen to the audio stream.

Make sure you don't have any problems on your analog ports for normal voice calls, otherwise, you may have some provider problems. Maybe you want to try a less new IOS, something like 12.4(20)T3 which may have fewer unknown issues. That, or something like 12.4(15)T9

TrustIT-Spiere Mon, 07/13/2009 - 11:41

Hi Nick,

Ok, I will try another IOS asap and will keep you posted. If this doesn't help with the fax problem, could there be any hardware error on the FXS VWIC? I've tried 2 of the 4 ports now and this doesn't help a thing.



Nicholas Matthews Mon, 07/13/2009 - 19:36

Hi Peter,

It's not likely a hardware problem, no. It's more likely either a software bug or issue on the provider network.


TrustIT-Spiere Mon, 07/13/2009 - 23:11

Hi Nick,

I'm thinking of implementing the Fax to mail script to see if that could bring any solution, so we can exclude the Cisco UC from the troubleshooting. Do you think that would be a good idea?


Nicholas Matthews Tue, 07/14/2009 - 04:42

Hi Peter,

The fax to mail script is more sensitive to failures than a normal fax machine, so I would not expect that to be a helpful troubleshooting step.



This Discussion