Multiple subnetworks in VLAN

Unanswered Question
Jun 18th, 2009

Hi,

can someone help me with this problem?:

I have c6500 with 2 vlans.

First: vlan10 is using ip subnet 192.168.100.0/24...clients are using default gateway 192.168.100.1

Second Vlan20 use subnet space 192.168.101.0/24...clients gateway is 192.168.101.1

In vlan10 will be SAN network with IP space 172.16.1.0/24 and in vlan20 SAN with subnet 172.16.2.0/24. I need these subnets 172.16.x.x will be visible and SANs can be replicated. How to configure c6500 to allow comunication???.

Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lubosbella Thu, 06/18/2009 - 06:04

Thank,

maybe better will be to see problem on picture (in attachment).

Sites are interconected by one wire in vlan20. So i cant create new VLAN there.

So how to setup switches that SANs can comunicate?.

Attachment: 
andrew.prince@m... Thu, 06/18/2009 - 06:13

You need to either:-

1) Enable IP routing

2) Make the link between the 2 buildings a trunk, and create a VLAN that spans both buildings

3) Perform Layer 2 trunking.

HTH>

lubosbella Thu, 06/18/2009 - 07:19

Thank,

this procedure is best, but im not sure if a switch in building B is managable and support to create VLANs.

If not, is possible to create in interface vlan20 second ip space/secondary ip address (ip address 172.16.2.0/24 secondary) and in interface vlan10 secondary ip address 172.16.1.0/24 ?

Then these subnets will be directly connected to c6500 and will be visible...

It is a good alternative idea?

andrew.prince@m... Thu, 06/18/2009 - 07:21

what version of software are the 6500's running, CatOS or IOS? Hybrid or Native? What supervisor modules are installed?

lubosbella Thu, 06/18/2009 - 07:29

Here is it:

IOS (tm) s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(18)SXD7b, RELEASE SOFTWARE (fc1)

ROM: System Bootstrap, Version 12.2(17r)S4, RELEASE SOFTWARE (fc1)

BOOTLDR: s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(18)SXD7b, RELEASE SOFTWARE (fc1)

Supervisor Engine 720 (Active) WS-SUP720-3B

andrew.prince@m... Thu, 06/18/2009 - 07:32

This supports L2/L3 interfaces.

You can create 2 new vlans and have them route over the existing IP vlan between the two sites.

lubosbella Thu, 06/18/2009 - 07:52

Thank,

and can you help me how to configure this routing? ....

- So we have:

interface Vlan10

ip address 192.168.100.1 255.255.255.0

interface Vlan20

ip address 192.168.101.1 255.255.255.0

- then i can add new VLANs:

interface Vlan30

ip address 172.16.1.1 255.255.255.0

interface Vlan40

ip address 172.16.2.1 255.255.255.0

But how to route them and assign them to interface?

andrew.prince@m... Thu, 06/18/2009 - 08:02

When you create the VLAN - you also need to create the VLAN SVI.

Building B would be

interface vlan 40

ip address 172.16.2.1 255.255.255.0

ip route 172.16.1.0 255.255.255.0 192.168.100.x

Building A

interface vlan 30

ip address 172.16.1.1 255.255.255.0

ip route 172.16.2.0 255.255.255.0 192.168.101.y

x=4th octect of vlan interface in Building A

y=4th octect of vlan interface in Building B

lubosbella Thu, 06/18/2009 - 10:28

Thank you very much Andrew.

Maybe some questions:

- i dont need to put this vlan 30 and 40 on same physicall interface? ... so physical interface where is connected building B to c6500 will be unchanged?

interface GigabitEthernet1/4

no ip address

switchport

switchport access vlan 20

switchport mode access

no cdp enable

spanning-tree portfast

- there are no others configuration changes for this routing except "ip routing"?

andrew.prince@m... Thu, 06/18/2009 - 10:40

Only the interfaces on the respective sites that connect to the SAN need to be in the VLANs.

The VLAN/physical connection that connects the 2 buildings together does not need to be touched.

I would imagine that you already have "ip routing" enabled. so other than the static routes I posted earlier, no more routing config needs to be applied.

HTH>

lubosbella Thu, 06/18/2009 - 11:19

Ok,

so one SAN interface which is connected to LAN is in building A. Here is SAN connected with one port to c6500. So config of this physical interface on c6500 will be:

interface GigabitEthernet1/5

no ip address

switchport

switchport access vlan 30 ???

switchport mode access

But if switch in building B is unmanagable then i cant configure this switch and i must to plug cable to this switch only....? but what than with vlan40?

Many thanks.

andrew.prince@m... Thu, 06/18/2009 - 11:30

switchport config is correct.

If the switch in B is unmanaged, then you have a long walk to go an configure it!!

lubosbella Thu, 06/18/2009 - 11:40

Ok if switch will be unmanagable then is better to buy new managable switch in building B...:)

Last question:

if i do a trunk link between buildings, is better to put SAN in building A in vlan 30 and put SAN in building in VLAN 40 or is better to use one VLAN (f.e.: 50) and put both SANs to this VLAN (in building A and B)?

Thanks.

andrew.prince@m... Fri, 06/19/2009 - 00:36

Lubo,

Having a remotely managed switch is always the best way forward, saves the walking to perform configurations!

If you have a trunk between the 2 buildings, then you can have the physical equipment in either building in the same vlan - which would be very nice.

Actions

This Discussion