Cisco 6500 Switch setup question

Unanswered Question
Jun 18th, 2009

Hello,

We currently are attempting to replace an older 5509 with a 6500 series switch (all version information will be below) but I am coming across a problem that I'd appreciate the community's help on please.

I'll start with posting the configuration of the new switch then describe the problem.

--------

Current configuration : 9033 bytes

!

upgrade fpd auto

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service counters max age 5

!

hostname Router

!

!

no aaa new-model

ip subnet-zero

!

!

!

mls ip slb purge global

no mls acl tcam share-global

!

!

!

!

!

!

redundancy

mode sso

main-cpu

auto-sync running-config

!

spanning-tree mode pvst

no spanning-tree vlan 1,22

no diagnostic cns publish

no diagnostic cns subscribe

fabric timer 15

!

vlan internal allocation policy ascending

!

!

interface GigabitEthernet1/1

description VLAN22 Dungeon Connection

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 22

switchport mode trunk

no ip address

!

interface GigabitEthernet1/2

no ip address

shutdown

!

interface FastEthernet2/1

switchport

switchport access vlan 22

no ip address

<<other fast ethernet ports omitted>>

!

interface Vlan1

no ip address

!

interface Vlan22

description Dungeon Switch

ip address 192.168.22.4 255.255.255.0

ip helper-address 192.168.20.24

ip directed-broadcast 101

!

router rip

version 2

network 192.168.20.0

network 192.168.22.0

!

ip default-gateway 192.168.22.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.22.1

!

no ip http server

!

access-list 101 permit udp host 192.168.20.93 any eq snmp

!

!

!

dial-peer cor custom

!

!

!

!

line con 0

line vty 0 4

login

!

no cns aaa enable

end

------

The problem is this: after I setup the switch the VLAN I want to establish (VLAN 22) shows to be down/down when I do a show interface command.

The G1/1 interface (the gig interface on the Supervisor) shows to be up/up as does the FastEthernet port 2/1 when I plug in my laptop. However, since the VLAN is down I can't communicate back to the core switch which is on the other end of the connection (a 6506E)

The new switch has the following version settings:

Cisco Internetwork Operating System Software

IOS (tm) s222_rp Software (s222_rp-IPSERVICES_WAN-M), Version 12.2(18)SXF16, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2009 by cisco Systems, Inc.

Compiled Tue 03-Mar-09 14:24 by kellythw

Image text-base: 0x40101040, data-base: 0x4295C840

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)

BOOTLDR: s222_rp Software (s222_rp-IPSERVICES_WAN-M), Version 12.2(18)SXF16, RELEASE SOFTWARE (fc2)

Router uptime is 17 hours, 49 minutes

Time since Router switched to active is 17 hours, 48 minutes

System returned to ROM by power cycle (SP by power-on)

System image file is "disk0:s222-ipservices_wan-mz.122-18.SXF16.bin"

cisco WS-C6506 (R7000) processor (revision 3.0) with 458752K/65536K bytes of memory.

Processor board ID SAL08239FVP

R7000 CPU at 300Mhz, Implementation 0x27, Rev 3.3, 256KB L2, 1024KB L3 Cache

Last reset from power-on

SuperLAT software (copyright 1990 by Meridian Technology Corp).

X.25 software, Version 3.0.0.

Bridging software.

TN3270 Emulation software.

2 Virtual Ethernet/IEEE 802.3 interfaces

144 FastEthernet/IEEE 802.3 interfaces

2 Gigabit Ethernet/IEEE 802.3 interfaces

381K bytes of non-volatile configuration memory.

32768K bytes of Flash internal SIMM (Sector size 512K).

Configuration register is 0x2102

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dario.didio Thu, 06/18/2009 - 04:32

Hi,

Did you create the VLAN?

conf t

vlan 22

name data

keep us posted!

HTH,

Dario

glen.grant Thu, 06/18/2009 - 05:21

Verify vlan is created with a show vlan command . The ports don't have spanning tree portfast on them so you may have to wait about 50 seconds while that runs before the L3 interface will come active . Otherwise there is no reason for the L3 interface not to come up . If you have that trunk connection up and active then the L3 interface should be active.

fullerton175 Thu, 06/18/2009 - 05:56

(message edited 6/18/09, 9:20AM CST

I had to disconnect all connections to the switch and bring the old one back online but I think I found the problem.

The VLAN was created but was showing down/down.

Now, when I first powered on the 6500 the GBIC interface was not physically plugged into the module on the supervisor engine (the g1/1 interface). I had plugged it into the module after the switch was already powered online

So, on a hunch I physically shut down the switch and brought it back online. All systems booted normally so that was good.

I then did:

show int

After the reboot VLAN 22 shows to be up/down which I believe is correct until I can plug in the uplink (the g1/1) to the network again and but that would have to wait until off hours since I obviously can't unplug the old siwtch during business hours.

Am I correct in that assessment about the status of the vlan 22?

When I perform a show vlan the GI1/1 shows to be in VLAN1 still too. I don't believe that should be the case

fullerton175 Fri, 06/19/2009 - 03:43

This problem has been resolved. The solution was, as I thought, pretty simple.

When testing your VLANs and connections, you have to be sure to have a device plugged into one of the ports on the switch. I don't know why this is but I'm guessing it has something to do with spanning trees.

I also placed the switch in transparent mode for vtp as well tweaked the settings a little to be this for the switch:

vlan 22

!

!

interface GigabitEthernet1/1

description VLAN22 Dungeon Connection

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

interface FastEthernet2/1

switchport

switchport access vlan 22

switchport mode access

interface Vlan22

description Dungeon Switch

ip address 192.168.22.4 255.255.255.0

ip helper-address 192.168.20.24

ip directed-broadcast 101

!

ip default-gateway 192.168.22.1

ip route 0.0.0.0 0.0.0.0 192.168.22.1

After these changes the switch worked great again. Thanks for all the assistance!

iyde Mon, 06/22/2009 - 09:06

'When testing your VLANs and connections, you have to be sure to have a device plugged into one of the ports on the switch.'

Well, it actually has to do with the fact that if nothing is connected to an interface, then it is down. In the case of a VLAN, the way to connect something to it is to have something active on either an access port in that VLAN or a trunk port on which that VLAN is allowed.

So if your physical problem with a port was causing no trunkports to be active, and you at the same time did not have any access port which is in VLAN 22 active, then the interface VLAN 22 will show up/down.

Your good old 2501 router did the same with it's e0 interface, if you did not connect anything to it.

HTH.

Actions

This Discussion