×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Issue FXO

Answered Question
Jun 18th, 2009
User Badges:

hi,

i have call manager 6.1 with a H323 gateway.

in the gateway i have 3 cards:

- one PRI : the calls work hine ( in and out)

- one card 4-Fxo: with 4 analog line : calls work fine (in and out)

- one card 4-fxo: with 4 gateway GSM: calls from site to outside work fine. but the call from outside dosn't work, the phone rings and when i tray to respond the call hang up :

this the config for the 4 voice port:

voice-port 0/3/0

input gain -3

output attenuation 4

echo-cancel coverage 24

no comfort-noise

cptone FR

timeouts interdigit 6

timeouts call-disconnect 5

timing hookflash-out 500

connection plar opx 100

impedance complex2

caller-id enable

Correct Answer by paolo bevilacqua about 8 years 2 months ago

Can you try "no battery reversal" ?

If still problem, get "debug vpm signal" with "term mon" for a failed call.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
dennisbehrens Thu, 06/18/2009 - 09:49
User Badges:

If the call rings properly, but answering causes a disconnect, this usually indicates a codec problem. Can you please post your dial-peers?

bsaid1977 Thu, 06/18/2009 - 10:00
User Badges:

thanks for replay

yes the ring is good, but tha call disconnect when i tray to answeer


the problem is with port 0/3/X




this my all dial peer:

dial-peer voice 100 voip

destination-pattern ...

session target ipv4:172.16.0.254

dtmf-relay h245-alphanumeric

codec g711ulaw

!

dial-peer voice 10 pots

destination-pattern 82..........

direct-inward-dial

port 0/0/1

!

dial-peer voice 11 pots

destination-pattern 83..........

incoming called-number 0522335486

direct-inward-dial

port 0/0/2

!

dial-peer voice 12 pots

destination-pattern 84..........

incoming called-number 0522972486

direct-inward-dial

port 0/0/3

!

dial-peer voice 9 pots

destination-pattern 81..........

direct-inward-dial

port 0/0/0

!

dial-peer voice 1 pots

destination-pattern 9..........

direct-inward-dial

port 0/2/0:15

forward-digits 10

!

dial-peer voice 125 pots

destination-pattern 7.............

direct-inward-dial

port 0/2/0:15

forward-digits 13

!

dial-peer voice 126 pots

destination-pattern 800...

direct-inward-dial

port 0/2/0:15

forward-digits 3

!

dial-peer voice 127 pots

destination-pattern 80..

direct-inward-dial

port 0/2/0:15

forward-digits 2

!

dial-peer voice 20 pots

destination-pattern 86..........

port 0/3/0

!

dial-peer voice 21 pots

destination-pattern 87..........

port 0/3/1

!

dial-peer voice 22 pots

destination-pattern 88..........

port 0/3/2

!

dial-peer voice 23 pots

destination-pattern 89..........

port 0/3/3

!

!

paolo bevilacqua Thu, 06/18/2009 - 10:06
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try:


voice-port x/y

no supervisory disconnect signal



note, if you use trunk-groups, you can reduce the many DPs to a single one.

bsaid1977 Thu, 06/18/2009 - 10:18
User Badges:

yes, i have the same config for both card 4-FXO

the first 4 port is connected to 4 analog lines (to telecom company) and all call are fine from inside to outside and from outside from inside.


but the seconde card 4-FXO are connected to 4 gateway GSM (to mobile phone company), i can make the call from inside to other number in the world, but i can't receive the call( just ring and han up when i tray to respond.

dennisbehrens Thu, 06/18/2009 - 10:19
User Badges:

Have you tried plugging the GSM Gateway lines into the other ports to isolate that it's not the FXO ports?

paolo bevilacqua Thu, 06/18/2009 - 10:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I've corrected my reply above, try and let us know.

bsaid1977 Thu, 06/18/2009 - 10:30
User Badges:

hi,

this command is to solve another problem, but i have testd this command without result.


yes i have tested the port 0/3/X , they work fine with analog line.

And if the port isn't good i can't make calls from inside to outsider vis this ports.


thanks for advice

bsaid1977 Thu, 06/18/2009 - 10:35
User Badges:

the company phone says that,

how i can use loop Start

paolo bevilacqua Thu, 06/18/2009 - 10:42
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Loop start is default.

Ground start is not used outside north america.

Correct Answer
paolo bevilacqua Thu, 06/18/2009 - 10:36
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Can you try "no battery reversal" ?

If still problem, get "debug vpm signal" with "term mon" for a failed call.

bsaid1977 Thu, 06/18/2009 - 10:41
User Badges:

i have read the document: Document ID: 8120


i used all command in this document, but issue doesn't mutch with this trooblshoot document.


thanks for your best effort

paolo bevilacqua Thu, 06/18/2009 - 10:47
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Nobody said that you have a disconnect supervision problem.


Please collect the debug indicated above.


dennisbehrens Fri, 06/19/2009 - 07:48
User Badges:

That looks like battery reversal is occurring and the Cisco gateway is disconnecting the call. Is this with "no battery-reversal" applied to the voice port?

bsaid1977 Fri, 06/19/2009 - 08:17
User Badges:

yes this the problem, thanks for all


now all calls are ok

Actions

This Discussion