T1 Clocking in Multilink

Unanswered Question
Jun 18th, 2009

I have a Multilink configuration which, after about 1 week, both member T1's start showing numerous errors. A simple reboot of the router resolves the problems.

On both central and remote routers, the T1's are configured to look at the provider line for the clock.

At the central site I am using a VWIC2-2MFT-T1/E1 which has both T1 ports on the card in a 2811 router.

At the remote site, I am using 2 separate WIC1DSU-T1V2 cards that each have a single T1 port in an 1841 router.

The question(s): Should I obtain clocking from the line? or internal? Should my remote site use the VWIC2-2MFT-T1/E1 card rather then two WIC1DSU-T1V2 cards?

Thanks,

Tim

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Thu, 06/18/2009 - 11:07

Ask the WAN provider if they supply clock on both sides of the circuits. Sometime that is the case, sometime is not.

What card you use doesn't matter.

John Blakley Thu, 06/18/2009 - 12:21

Tim,

Put this in global config, but change as needed:

network-clock-select 1 T1 0/0/0

Under the controller that you want to get your timing from, put the following:

controller t1 0/0/0

clock source line primary

The difference between you and I is that I was getting timing from the same provider for three different WICs.

What the above does is tell the router that controller x is going to be the primary clocking mechanism for the other cards. Then the network-clock-select command is setting the t1 controller to be the primary clocking source for all other cards on the router.

I had multiple wics in one router and getting timing from the provider. The cards were all fighting each other for timing, and I was seeing CRC, framing, input errors, and aborts before doing this.

HTH,

John

Tim Johnson Mon, 06/22/2009 - 10:27

John - thanks for the info. Glad to hear I'm not going crazy.

Question - would this be done on both routers? Or just the central or remote router?

A little more background...The central router (2811) has 6 T1 lines all configured to obtain clock from the line (provider sourced). The remote router (1841) has 2 T1 lines obtaining clock from the line also. These two lines are configured as the Multlink for both remote and central router. No other site (the other 4 T1 lines in the central router) are having issues.

Thanks,

Tim

John Blakley Mon, 06/22/2009 - 10:30

Tim,

It should be done on the routers that you're seeing the issue on, and that's about it. You should see your errors clear up.

HTH,

John

Tim Johnson Mon, 06/22/2009 - 10:34

When the errors occur - it is showing on both the central and remote router serial interfaces, so that would mean make the change to both routers.

My concern is if I made the change on the central router, that would require me to make changes on all other remote routers with the T1 connection to the central router. If it's needed, it's needed, I just wanted to follow KISS.

Thanks again,

Tim

John Blakley Mon, 06/22/2009 - 10:36

Well, you'll need to change the ones that you have control over. It will clear up on the other end (PE) on it's own. (Hopefully.) The provider saw a ton of errors coming from our equipment too until I made these changes. It took me DAYS to figure out how to fix it.

Tim Johnson Mon, 06/22/2009 - 11:08

Ok - one last item. I looked at the 1841, however there is no option for the network-clock commands. Same for the controller itself.

The 2811 has the options for configuring the T1 controllers, as well as network-clock-participate or -source, however hte 1841 does not have these options. Any thoughts?

Thanks,

Tim

I know this is an old thread but i thought i would chime in an say that this worked for me. We were having the same issues described by the initial post with random CRC and Input errors. After setting the clock to internal and pointing it to the T1 card all issues were resolved. 2800 series router going to an older 3700 series. Worked like a charm for our T1 emulation.

Actions

This Discussion