Virtual-Dot11Radio0 doesn't exists at boot ...rejecting commands at startup

Unanswered Question
Jun 18th, 2009

my current config has two interfaces; outside and inside as follows:

interface FastEthernet0/0

description InterNet uplink

ip address dhcp

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

no cdp enable

no mop enabled

interface FastEthernet0/1

description IntraNet downlink

ip address a.a.a.a m.m.m.m

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

no cdp enable

no mop enabled

ip nat inside source list aclWhatever interface FastEthernet0/0 overload

ntp server n.n.n.n source FastEthernet0/0 prefer

... this is working very well, now suppose I want to switch from my fixed ISP to a radio interface as follows:

interface Dot11Radio0/1/0

description InterNet uplink

ip address dhcp

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

no cdp enable

no mop enabled

...

station-role non-root

ssid ssidWhatever

interface FastEthernet0/1 ... unchanged; same as before

description IntraNet downlink

ip address a.a.a.a m.m.m.m

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

no cdp enable

no mop enabled

... PROBLEM IS I can't place the following analog commands:

ip nat inside source list aclWhatever interface Dot11Radio0/1/0 overload

ntp server n.n.n.n source Dot11Radio0/1/0 prefer

... since the radio IP address is assigned to Virtual-Dot11Radio0 which I can overcome as follows:

ip nat inside source list aclWhatever interface Virtual-Dot11Radio0 overload

ntp server n.n.n.n source Virtual-Dot11Radio0 prefer

... only AFTER the radio interface is up and running and this works great BUT when the router is starting the lines are refused because at this time Virtual-Dot11Radio0 doesn't exists and I have to place the lines MANUALY every time I reboot the router so, how can I overcome this issue ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hadbou Wed, 06/24/2009 - 17:11

virtual-dot11radio interfaces are used to communicate with other repeaters. If there is no repeater associates with the AP, the AP

puts the virtual-dot11radio interface to down.

One most common related problem is Aironet extension. If Aironet extension is enable, Cisco APs may misidentify other vendor's wireless adapter (i.e.non CCX compliant clients) as repeater. As a result, the AP brings up the virtual-dot11radio interface for a brief moment. You may try You may turning off the corresponding SNMP alarm.

nlariguet Sun, 07/19/2009 - 18:41

"virtual-dot11radio interfaces are used to communicate with other repeaters."

... what are you talking about ?

the virtual-dot11radio interfaces in my config are managed by the IOS and I have no control over them, and I don't have anything remotely related to a reapeter as you can see in the config I posted.

Roman Rodichev Sat, 07/25/2009 - 19:32

oh this sucks! I see exactly what you mean. If you had a static IP address assigned to dot11radio0/1/0, then you could use it for "ip nat", but you want to use DHCP, and IOS doesn't assign this IP to both virtualdot0 and dot0/1/0 interfaces, only to virtualdot0. I'll think about this one. Did you find a solution by any chance?

Regards,

Roman

nlariguet Sat, 07/25/2009 - 21:26

not at all ... stuck

thinking a bit about "fixing" this behavior with some tcl script to make something like shut/ssid whatever/no shut/nat blah blah/ntp blah blah but it seems overkill ain't it ?

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode