VTP and Maximum Vlans Supported

Unanswered Question
Jun 18th, 2009
User Badges:

Hello all,


i'm using a Catalyst 6500 in a datacenter as a VTP server with about 15 smaller switches (2950, 2960, etc) connected to it in VTP client mode. Yesterday i added a pair of new VLANs on the 6500 and saw that all the 2950 switches went into transparent mode because the maximum number of supported Vlan on that switches has been reached. I do not need every VLAN on every switch so i would like to filter them, but i cannot find a way to do this: every 2950 always take the full vlan list from the 6500 and become transparent. I used "switchport trunk allowed" and also tried VTP pruning without success. For example, i have configured vlans 1-100 on the 6500 but i want that a 2950 below him to get only vlans 1-10 so it doesn't get full and can remain in VTP client mode. Is it possible, or there is any workaround to this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Giuseppe Larosa Thu, 06/18/2009 - 23:59
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Simone,

>> Is it possible, or there is any workaround to this?


for some of these switch platforms an IOS upgrade can help to gain a bigger Vlan range.

However, check if there are any unused Vlans that could be removed.


Otherwise you need to coexist with VTP transparent mode devices that need to be managed individually.



Hope to help

Giuseppe


glen.grant Fri, 06/19/2009 - 04:36
User Badges:
  • Purple, 4500 points or more

The "switchport trunk allowed command should fix that . Do that on both sides of the link to the 2950's . If you are currently allowing everything then you would have to use the "switchport trunk allowed vlan remove 11-100 " command to prune off the vlans not needed. We ran into this ourselves with a 2950 and this fixes the issue as this will restrict the spanning tree instances on the switch to the allowed list . You may have to manually force it back to client mode after you make the change. Don't get confused by the vlan database , you will still "see" all the vlans in the database these just will not be allowed across the trunk thus reducing the spanning tree instances on the switch.

simone.barbarella Fri, 06/19/2009 - 05:06
User Badges:

I tried this without success. When i then try to type "vtp mode client" on the 2950 it immediately reverts to transparent mode. It doesn't seem a spanning tree instances issues but it's related to the number of VLANs transmitted by VTP which are more than 2950 can handle..

Giuseppe Larosa Fri, 06/19/2009 - 13:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Glen,

the issue is with the number of vlans in the VTP database.

I had the same trouble on a C2912 connected to a C6500.

When the 129 th vlan was created on the C6500 the C2912 went in vtp transparent mode to protect itself.


There are actually two limits (that can be different) for a Cisco LAN switch:

the max number of Vlans in the VTP DB

the max number of STP instances


There are devices that have max 128 vlans and max 64 STP instances.


I agree that the number of STP instances can be controlled with switchport trunk allowed, but this doesn't help in controlling the VTP DB size because VTP messages travel in a single vlan on the trunk ports.


At least this is my understanding of the original question.

Also nowdays in some campus networks of our customer we face these issues.


Hope to help

Giuseppe


jimmysands73_2 Fri, 06/19/2009 - 18:47
User Badges:
  • Silver, 250 points or more

I am always impressed by persons such as yourself and your answers.....nice explanation.

palukuri77 Sat, 06/20/2009 - 06:35
User Badges:

Hi,


I hope by now you might have well known of the solution. But I would just like to add that here of the possible solution which I think of for your situation.


1. Delete the vlan database file on the 29xx switches.

2. Configure VTP in transparent

3. Create only VLANs which you require on it.


Also make sure the uplink to the 65xx switch is not connected or disabled in this process.


Thanks,

Subhash

Actions

This Discussion