DFM 3.1.3 and CATOS switches

Unanswered Question
Jun 19th, 2009

After we upgraded our DMF from 3.1.1 to 3.1.3 we get a memory ExcessiveFragmentation error on all Cat OS switches. We have rebooted some of the switches but DFM still report errors on the switches. How do we fix this problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
sbrox Tue, 06/23/2009 - 00:50

Cisco Systems, Inc. WS-C2948\X0ACisco Catalyst Operating System Software, Version 6.1(1)


Cisco Systems, Inc. WS-C4912\X0ACisco Catalyst Operating System Software, Version 7.4(3)

paul.parquet Wed, 09/16/2009 - 02:19

I've got the same error with a WS-C6509\X0ACisco Catalyst Operating System

Software, Version 8.2(1).

After this error appears, the CPU switchover without reason.

Is it a linked effect ?


Joe Clarke Wed, 09/16/2009 - 21:01

Sorry, I missed this follow-up. If you're still seeing this event, try removing these switches from DFM, then re-add them. DFM should only try and manage the processor and not the memory pools.

sbrox Thu, 09/17/2009 - 01:38

I have deleted and readded this switches in DFM but I still get the same memory fragmentation error

Joe Clarke Thu, 09/17/2009 - 07:50

Post a screenshot of the Detailed Device View for one of these switches. That is found under DFM > Device Management > Device Details.

Joe Clarke Mon, 10/12/2009 - 05:31

This is the RME Detailed Device Report. I wanted to see the DFM Detailed Device View under DFM > Device Management > Device Details.

sbrox Tue, 10/13/2009 - 04:55

The screendump is from the "Print" function in the Detailed Device View in DFM and not from RME.

I have done a new sceendumt without use of the "Print" function

Joe Clarke Tue, 10/13/2009 - 07:22

You should not have a Memory section for this device. Post your NMSROOT/objects/smarts/conf/discovery/oid2type.conf file.

Joe Clarke Thu, 10/15/2009 - 08:34

This all checks out. I cannot reproduce locally (i.e. my 2900 CatOS switches do not have a Memory category). I recommend you open a TAC service request so the developers can take a look at this.

jcopelandghs Tue, 10/20/2009 - 12:35

Sbrox did you get anywhere with the TAC on this one per jclarke's direction? I have noticed we have the same thing showing up now that we've upgraded.

We have a few CatOS boxes around that are showing this.

jcopelandghs Thu, 10/22/2009 - 07:32


Sorry to bug about this issue but I thought maybe you would notice this and be able to give some input. I have opened a TAC case #612766109 about this.

So far I was advised to raise the threshold to five which it was already at. I went ahead and raised this fragmentation threshold to 10 but it will seems to be causing an alert. Is there anythign else I should do to put this case going in the right direction?

FYI here is an example DFM event:

MANAGED OBJECT TYPE = Switches and Hubs

EVENT DESCRIPTION = ExcessiveFragmentation::Component=MEM-*.*.*.*/9 [CLUSTER];ComponentClass=Memory;ComponentEventCode=1030;FreeMemory=7468 KB;TotalMemory=7480 KB;FragmentationThreshold=10;FreeMemoryPct=99.83957219251337 %;LargestFreeBuffer=2 KB;LargestFreeBufferPc


This Discussion