translation-profile not working

Unanswered Question
Jun 19th, 2009
User Badges:

I am trying to put a translation rule on my outbound (to the PSTN) POTS dial-peer and it does not take. Here is my config:


voice translation-rule 950

rule 1 reject /4035551234/

!

voice translation-profile dave

translate calling 950

!

dial-peer voice 993 pots

translation-profile outgoing dave

destination-pattern 4034441234

no digit-strip

direct-inward-dial

port 4/0/0:23

!


So when I call 4034441234 it matches on the 993 dial-peer but the translation-profile does not work?


Any ideas why?


Cheers!

Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
parshah Fri, 06/19/2009 - 08:36
User Badges:
  • Cisco Employee,

Dave,


Not sure what you are trying to achieve here.


Your POTS dial-peer has dest-pattern of 4034441234. The voice trans-profile is configured to reject calling number 4035551234


However, you are dialing 4034441234. Is the calling number 4035551234? Can you confirm that by debug voice ccapi inout that the called is 4034441234 and calling is 4035551234.


Thanks,

infosateng Fri, 06/19/2009 - 08:44
User Badges:

Yes. All I am trying to achieve here is to make a tranlation-profile work. I want it to reject a call when it comes from a specific phone number.


The called number is 4034441234 - I setup a specific dial-peer so that I would always catch the call and could leave my production DP's alone.


My calling number is 4035551234 and I have confirmed it with the debug.


For some reason I cannot get it to match on the translation profile?

parshah Fri, 06/19/2009 - 08:56
User Badges:
  • Cisco Employee,

Hi,


Can you change your voice trans rule to this


rule 1 reject /^4035551234/


Thanks,

parshah Fri, 06/19/2009 - 09:05
User Badges:
  • Cisco Employee,

Hmmmm,


Can you send me the debug following debug


1. debug voice ccapi inout

2. debug isdn q931


Thanks,

parshah Fri, 06/19/2009 - 13:44
User Badges:
  • Cisco Employee,

Ok,


I think I got what your issue is. Just by matching a translation profile, you will not be able to block the call. You need to use the call-block command in the dial-peer to match a translation profile where the reject rule is. And if that matches than you can block.


Now, I looked around but the call-block command is as follows


call-block translation-profile incoming


As you can see this has incoming and not outgoing. I checked on my routers and there is no option for outgoing.


So for you to be able to get this to work, what you will need to do is create a blank incoming voip dial-peer


dial-peer voice X voip

incoming called number .

call-block translation-profile incoming



So you will have to remove the translation profile from the POTS dial-peer


Look at the attached doc for more info on the call-block command. This was the only way I found that you can block calls using translation profiles.


The other way is to use COR but with COR you cannot selectively block calls.


Thanks,




Attachment: 
paolo bevilacqua Sun, 06/21/2009 - 01:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Correct, call-block works with voip DP, reject in translation-rule works in pots DP, and not vice-versa.


Not intuitive at all, but that's cisco.


dnazlidis Sat, 06/22/2013 - 02:00
User Badges:

This is how it works in my situation if I apply to yours, on as5300 and c5300-js-mz.123-26.bin


voice translation-rule 950

rule 1 reject /4035551234/

!        

voice translation-profile dave

translate calling 950

!

dial-peer voice 993 pots


call-block translation-profile incoming dave

call-block disconnect-cause incoming call-reject

destination-pattern 4034441234

no digit-strip

direct-inward-dial

port 4/0/0:23

Actions

This Discussion