ARP/L1 issue?

Unanswered Question

I have 2 routers connected by an HP switch. The 2 routers have incomplete ARP entries for each other. The switch sees the correct MAC address on their respective ports. I've changed cables on both sides, moved switch ports for both devices, and have not been able to resolve this. One router will have an ARP entry for the other every so often, but still no comms between the two. I've assigned static ARP entries just for kicks, and got the same results. Here are more specifics about each router:

Router 1: 2801 (12.4(22)T) port F0/1

Router 2: 3825 w/ HWIC-4ESW port F0/0/3 (in assigned access vlan)

I've also noticed that the vlans on the HWIC module apparently are completely independent of the vlans defined on the router itself. For example, I have G0/1 of my 3825 trunked with 2 subinterfaces (vlan 8 & 40). I have vlan 500 assigned to one of my HWIC ports. The router vlan database only shows the HWIC vlan definitions.

Is there anything else I can try to narrow the problem down? I tried removing all assigned vlans on the HWIC card, but still no luck.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
prasad.gsmc Sat, 06/20/2009 - 22:41


can you provide more information on the VLAN and sub interface config of the routers. Also if possible connect backto back and ensure that the communication happens properly. then you may proceed to switch.

Hope that the hp switch interface leading to the routers are carrying all required vlans ?

Giuseppe Larosa Sun, 06/21/2009 - 03:38

Hello Kevin,

check that the two ports in HP are in the same vlan if access-layer ports.

if you are using subinterfaces on C2801:f0/1 you need to create the vlans on the HP switch and the port to 2801:f0/1 has to be a L2 trunk that:

a) carries all the required vlans 8,40

b) agrees with other side on the native vlan identity that travels untagged on the 802.1Q trunk.

subinterfaces on 2801 need the command

enc dot1q vlan-number

you should define the same vlans on the HWIC ip addresses on int vlan8 and int vlan 40.

the link has to be an 802.1Q trunk and needs to satisfy at the same requirements listed above.

Hope to help


Thanks everyone for your replies. All ports are treated as access ports. These are the interfaces in question that cannot seem to ARP. It acts as if they are in the wrong vlan, but the HP switch has both ports in vlan 500 as untagged (i.e. access port or native vlan on a trunk)

Here are the relevant configs.

Router 1:

interface FastEthernet0/1

ip address

speed 100


arp timeout 1800


Vlan 500

untag 7-8

(the respective ports for Router 1 & 2)

Router 2:

interface FastEthernet0/0/3

switchport access vlan 500

speed 100


interface Vlan500

ip address

ip virtual-reassembly

arp timeout 1800

Giuseppe Larosa Mon, 06/22/2009 - 07:58

Hello Kevin,

you have been kind to report the solution of your problem.

This makes this a complete case

Best Regards



This Discussion