cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
244
Views
4
Helpful
3
Replies

Help on Route-filter

ronald.ramzy
Level 1
Level 1

Hi,

Our Service Provider provides remote office connection though MPLS using BGP.

when I do sh ip route , i see lots of unwanted routes.

can someone help with correct route-map filter commands to restrict these routes.

Interface connected to Service-provider network Serial 0/0

Interface connected to LAN Fe 0/1

**************

HeadQuarters**

**************

interface s 0/0

ip address 172.16.100.1/30

interface e 0/1

ip address 192.168.1.140/30

Other networks are 192.168.5.0/24

172.20.2.0/21

Remote Office network is 10.10.10.0/23 &&

192.168.100.0/24

Unwanted network from service provider

88.80.76.0/24

172.16.105/24

172.16.99.0/24

85.15.77.0/23

3 Replies 3

Istvan_Rabai
Level 7
Level 7

Hi Ron,

You can apply a prefix-list inbound to the updates coming from the Service Provider. Prefix-lists are faster and require less processor cycles.

Example:

ip prefix-list TEST seq 5 deny 88.80.76.0/24

ip prefix-list TEST seq 10 deny 172.16.105/24

ip prefix-list TEST seq 15 deny 172.16.99.0/24

ip prefix-list TEST seq 20 deny 85.15.77.0/23

ip prefix-list TEST seq 25 permit 0.0.0.0/0 le 32 (this line permits everything else that is not denied by earlier statements)

router bgp xxx

neighbor y.y.y.y prefix-list TEST in (y.y.y.y is the service provider neighbor router ip address).

Cheers:

Istvan

Thanks.

Can you help with route-map commands as well.

Istvan_Rabai
Level 7
Level 7

Hi Ron,

The same can be implemented on route-map the following way:

access-list 1 permit 88.80.76.0 0.0.0.255

access-list 1 permit 172.16.105.0 0.0.0.255

access-list 1 permit 172.16.99.0 0.0.0.255

access-list 1 permit 88.15.77.0 0.0.0.255

route-map FROM_SP deny 10

match ip address 1

route-map FROM_SP permit 20

router bgp xxx

neighbor y.y.y.y route-map FROM_SP in

Cheers:

Istvan

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: