mwi not turning on. is my configuration correct?

Unanswered Question
Jun 21st, 2009
User Badges:

looking for some insight as to what my problem is.


My VOIP platform is a 2811 running c2800nm-ipvoice-mz.124-24.T.bin & CME 7.1 & my phones are 7971GEs also running the latest SCCP. Voicemail is located at extention 4444 and is reached through dialpeer 4400.


dial-peer voice 4400 voip

destination-pattern 44..

session protocol sipv2

session target ipv4:10.10.10.11

session transport tcp

dtmf-relay rtp-nte

codec g711ulaw

no vad


My two phones have extensions 4445 and 4446. I call 4445 and after 5 seconds of NOAN the call is forwarded to voicemail and i leave a voicemail. my voicemail server then sends a SIP NOTIFY to MWI to my router. here is the


"DEBUG CCSIP MESSAGES"


Jun 19 13:40:50.735: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

NOTIFY sip:[email protected]:5060;user=phone SIP/2.0

FROM: <sip:10.10.10.11:5067;transport=Tcp;ms-opaque=454001ffb3eff339>;epid=F76A3455EB;tag=febcca39a8

TO: <sip:[email protected]:5060;user=phone>

CSEQ: 2 NOTIFY

CALL-ID: b70eb54764c54d0d9e3b44ffb045cdd8

MAX-FORWARDS: 70

VIA: SIP/2.0/TCP 10.10.10.11:47953;branch=z9hG4bKa4b7b089

CONTACT: <sip:[email protected]:5060;user=phone>

CONTENT-LENGTH: 98

EVENT: message-summary

SUBSCRIPTION-STATE: terminated

USER-AGENT: RTCC/3.1.0.0

CONTENT-TYPE: application/simple-message-summary


Messages-Waiting: yes

Message-Account: sip:[email protected]:5060;user=phone

Voice-Message: 11/8


Jun 19 13:40:50.739: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 481 Call Leg/Transaction Does Not Exist

Date: Fri, 19 Jun 2009 13:40:50 GMT

From: <sip:10.10.10.11:5067;transport=Tcp;ms-opaque=454001ffb3eff339>;epid=F76A3455EB;tag=febcca39a8

Content-Length: 0

To: <sip:[email protected]:5060;user=phone>;tag=563880-1462

Call-ID: b70eb54764c54d0d9e3b44ffb045cdd8

Via: SIP/2.0/TCP 10.10.10.11:47953;branch=z9hG4bKa4b7b089

CSeq: 2 NOTIFY


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
m.matteson Sun, 06/21/2009 - 17:18
User Badges:


here is my configuration.


ccme#sh run

Building configuration...



Current configuration : 2593 bytes

!

! Last configuration change at 17:55:21 UTC Fri Jun 19 2009

! NVRAM config last updated at 15:21:06 UTC Fri Jun 19 2009

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ccme

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable password cisco

!

no aaa new-model

!

ip source-route

!

ip cef

!

ip name-server 10.10.10.10

no ipv6 cef

multilink bundle-name authenticated

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

fax protocol cisco

sip

bind control source-interface FastEthernet0/0

bind media source-interface FastEthernet0/0

header-passing

!voice-card 0

!

archive

log config

hidekeys

!

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/2/0

no ip address

shutdown

no fair-queue

!

interface Async0/0/0

no ip address

encapsulation slip

!

ip forward-protocol nd

!

no ip http server

!

tftp-server flash:cnu70.8-4-1-23.sbn

tftp-server flash:cvm70sccp.8-4-1-23.sbn

tftp-server flash:dsp70.8-4-1-23.sbn

tftp-server flash:jar70sccp.8-4-1-23.sbn

tftp-server flash:music-on-hold.au

tftp-server flash:term70.default.loads

tftp-server flash:term71.default.loads

tftp-server flash:SCCP70.8-4-2S.loads

tftp-server flash:apps70.8-4-1-23.sbn

!

control-plane

!

!mgcp fax t38 ecm

!

dial-peer voice 4400 voip

destination-pattern 44..

session protocol sipv2

session target ipv4:10.10.10.11

session transport tcp

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

sip-ua

mwi-server ipv4:10.10.10.11 expires 3600 port 5060 transport tcp unsolicited

!

telephony-service

max-ephones 5

max-dn 5

ip source-address 10.10.10.2 port 2000

load 7971 SCCP70.8-4-2S.loads

voicemail 4400

max-conferences 8 gain -6

moh music-on-hold.au

transfer-system full-consult

create cnf-files version-stamp 7960 Jun 19 2009 12:56:07

!

ephone-dn 1

number 4445

call-forward noan 4400 timeout 5

!

ephone-dn 2

number 4446

!

ephone 1

mac-address 0019.305D.41C8

type 7971

mwi-line 1

button 1:1

!

ephone 2

mac-address 000A.B79A.D5C0

button 1:2

!

line con 0

line aux 0

line 0/0/0

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

exec-timeout 0 0

password cisco

logging synchronous

login

!

scheduler allocate 20000 1000

end


ccme#


david-lima Mon, 06/22/2009 - 05:15
User Badges:
  • Bronze, 100 points or more

Hi frien, did you have the MWI ON/OFF configured?

ephone-dn 30

number 8000....

mwi on

!

ephone-dn 31

number 8001....

mwi off

All the best

David.

m.matteson Mon, 06/22/2009 - 05:32
User Badges:

is that neccessary if i am using unsolicited notify for MWI? would that be why the CALL-ID fields in the SIP messages don't match with the call that actually left the voicemail?

Actions

This Discussion