FXO disconnect problem on CME install in China

Unanswered Question

We are having some FXO disconnect problems at a site in Shanghai China. Does anyone have any experience with a CME install in this region using CNC (China Telecom) as a provider? The system works fine for a few weeks and then randomly get two of the FXO ports stuck open and have to shut/no shut them to get them cleared. We've tried a few custom CPTones and several variations of supervisory disconnect, no battery reversal, etc...




Any help is greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Mon, 06/22/2009 - 04:39
User Badges:
  • Red, 2250 points or more

Hi Jeff,


I would suggest trying this test:

Call from an FXO to an IP phone. Hang up on the analog phone and stay off hook on the IP phone. If your IP phone doesn't automatically disconnect then you have disconnect problems.


This will manifest itself as stuck ports if someone transfers a call out to the PSTN. Since neither side will be able to initiate a disconnect, the call will stay up.


My first suggestion is to to try 'supervisory disconnect dualtone mid-call' along with 'cptone CN'.


If this doesn't work, making a custom disconnect may be the solution. I wrote a long post on this previously:


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&topicID=.ee6c829&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40^1%40%40.2cd249ca/3#selected_message




hth,

nick

Actions

This Discussion