Why use service policy input command (macro)

Unanswered Question
Jun 22nd, 2009
User Badges:

Hello


I'm a little confused.


interface FastEthernet0/1

description IP Phones

switchport access vlan 20

switchport mode access

switchport voice vlan 30

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input AutoQoS-Police-CiscoPhone



Why do you use the service-policy input command when you already use mls qos trust commands? Is it layer 2 or layer 3 qos? If both, also why?


Wouter

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ivillegas Fri, 06/26/2009 - 10:36
User Badges:
  • Silver, 250 points or more

To attach a policy map to an interface, use the service-policy input command.

service-policy input policy-map name


The "mls qos trust" and "service-policy input" cannot be used together. The policy-map and the trust commands are mutually exclusive.


rmedvedev Mon, 08/17/2009 - 08:12
User Badges:

This service-policy is added automatically when you type "auto qos voip cisco-phone" on interface. If "mls qos trust" and "service-policy input" cannot be used together why it is both added?

Actions

This Discussion