2811 with 4 ADSL, connection problem

Unanswered Question
Jun 23rd, 2009

Hi All,

This has probably been answered some where but I can't find the answer.

I have a 2811 with 4 adsl cards fitted and a Ethernet connection to the LAN. I have configured all the ADSL's and they appear to be working.

Problem:

I can only get 1 link to pass traffic, I think it's a fault with the NAT but not sure how to fix it.

I've enclosed the router configuration with the IP address changed.

I would be grateful of any help

Ta

Graham

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Tue, 06/23/2009 - 01:05

You need four ip nat inside statements, one for each interface.

Also you may need to use route maps in nat statement.

You do no need any ip virtual reassembly command.

gnich Tue, 06/23/2009 - 01:21

Will I need 4 access list staments as well then?

gnich Tue, 06/23/2009 - 02:32

OK

Being dumb here,

How do i get the nat to use all 4 interfaces as when I try to add another interface eg

ip nat inside source list 1 interface ATM0/3/0.1 overload

it just overwrites the entry as opposed to associating ATM0/3/0.1 with access list 1.

Ta

Graham

Paolo Bevilacqua Tue, 06/23/2009 - 03:08

You have four interfaces, ATM0/x/0.1 where x goes from 0 to 3.

You should be able to enter them all, or use route-map instead of list.

gnich Wed, 06/24/2009 - 02:12

Thanks for the help.

It's starting to come together but now the problem has changed.

I've got lines 1 and 3 working together (line 2 is in use on the old router) but line 0 has two problems.

1 --- Line 0 IP overlaps with line 1 IP, (initially I had been given the wrong IP for line 0)

2 --- Line 0 will not work at the same time as line 3. if either is enabled on its own it works OK but if both are enabled there is no response from either of them

Current config is (I know some are shown shutdown)

interface ATM0/0/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0/0.1 point-to-point

description BE-1

ip address aaa.aaa.aaa.aaa 255.255.240.0

ip nat outside

ip virtual-reassembly

shutdown

no snmp trap link-status

atm route-bridged ip

pvc 0/101

oam-pvc manage

encapsulation aal5snap

!

!

interface ATM0/1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/1/0.1 point-to-point

description BE-2

ip address bbb.bbb.bbb.bbb 255.255.240.0

ip nat outside

ip virtual-reassembly

no snmp trap link-status

atm route-bridged ip

pvc 0/101

oam-pvc manage

encapsulation aal5snap

!

!

interface ATM0/2/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/2/0.1 point-to-point

description BT-1

ip address ccc.ccc.ccc.ccc 255.255.255.0

ip nat outside

ip virtual-reassembly

no snmp trap link-status

atm route-bridged ip

pvc 0/101

oam-pvc manage

encapsulation aal5snap

!

!

interface ATM0/3/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/3/0.1 point-to-point

description O2-1

ip address ddd.ddd.ddd.ddd 255.255.248.0

ip nat outside

ip virtual-reassembly

no snmp trap link-status

atm route-bridged ip

pvc 0/101

oam-pvc manage

encapsulation aal5snap

!

!

ip route 0.0.0.0 0.0.0.0 eee.eee.192.1

ip route 0.0.0.0 0.0.0.0 fff.fff.104.1

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat pool BE-2 aaa.aaa.aaa.aaa aaa.aaa.aaa.aaa netmask 255.255.240.0

ip nat pool BE-1 bbb.bbb.bbb.bbb bbb.bbb.bbb.bbb netmask 255.255.240.0

ip nat pool O2-1 ccc.ccc.ccc.ccc ccc.ccc.ccc.ccc netmask 255.255.248.0

ip nat pool BT-1 ddd.ddd.ddd.ddd ddd.ddd.ddd.ddd netmask 255.255.255.254

ip nat inside source route-map BE-1-map pool BE-1

ip nat inside source route-map BE-2-map pool BE-2

ip nat inside source route-map BT-1-map pool BT-1

ip nat inside source route-map O2-1-map pool O2-1

ip nat inside source route-map O2-2-map pool O2-2

!

logging trap debugging

access-list 1 remark INSIDE_IF=FastEthernet0/0

access-list 1 remark SDM_ACL Category=2

access-list 1 permit zzz.zzz.zzz.zzz 0.0.0.255

no cdp run

!

!

route-map O2-1-map permit 10

match ip address 1

match interface ATM0/3/0.1

!

route-map O2-2-map permit 10

match ip address 1

match interface FastEthernet0/1

!

route-map BE-2-map permit 10

match ip address 1

match interface ATM0/1/0.1

!

route-map BE-1-map permit 10

match ip address 1

match interface ATM0/0/0.1

!

route-map BT-1-map permit 10

match ip address 1

match interface ATM0/2/0.1

Giuseppe Larosa Fri, 06/26/2009 - 00:56

Hello Graham,

>> Line 0 IP overlaps with line 1 IP, (initially I had been given the wrong IP for line 0)

fix this give the correct ip address to line 0 and then try again.

Hope to help

Giuseppe

Actions

This Discussion