frame relay

Unanswered Question
Jun 23rd, 2009

I am trying to set a frame relay lab so I can create the cloud and proceed with my BCSI exam training. I have


2 x 2610 with 2 serial interfaces

1 x 2510 w/ 2 serial interfaces

2 x 2900 XL switches


Please help


Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (11 ratings)
Loading.
Giuseppe Larosa Tue, 06/23/2009 - 11:24

Hello ocporbust,

I would look for a 2500 with more serial interfaces to be used as FR switch. This would allow you to have three FR DTE routers and to emulate all the terrible NBMA issues with EIGRP, OSPF and RIP.


To be noted that you can use A/S interfaces with the only limit that when used in sync mode they cannot go faster then 128 kbps: it is enough to configure accordingly the other sides.


For each connection you need a V.35 DTE and a V.35 DCE cable or the equivalent composite cable.


for FR switching see


http://www.cisco.com/en/US/docs/ios/wan/configuration/guide/wan_cfg_frm_rly_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1055601


Hope to help

Giuseppe



cisco steps Tue, 06/23/2009 - 12:32

Giuseppe Thanks for the link, is there anyway you can help with the physical setup..


I have 3 router each w/ 2 serial interfaces, I have 3 DCE/DTE cables.


where so I start as far as cabling.


Thanks

cisco steps Tue, 06/23/2009 - 12:43

here is what I did so far. I connected

r1--s0---DCE to r2--s0--DTE

r1--S1---DCE to r3--s1--DTE


is this how its suppose too


Thanks

Giuseppe Larosa Tue, 06/23/2009 - 20:47

Hello Octorbust,

the setup is correct.


You need to configure the clock rate command on the side where the DCE cable is connected.


you can check this with

sh controller ser x/y


it will say DTE cable detected or DCE cable detected.


To be noted that OSI L1 DCE and FR L2 DCE can be on the two different sides but for clarity it is usually DCE cable on the FR switch side.


Hope to help

Giuseppe


cisco steps Thu, 06/25/2009 - 07:54

Thanks Giuseppe ,


what I need now is to configure the router to create the cloud,

I spent 2 days trying to create but no success. Can you help or provide a config example to do that

.. Gracias

cisco steps Thu, 06/25/2009 - 11:14

still no go, here is my config based on the link provided.

========================================


R3#sho run

Building configuration...


Current configuration:

!

version 11.0

service udp-small-servers

service tcp-small-servers

!

hostname R3

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

encapsulation frame-relay

no fair-queue

clockrate 64000

!

interface Serial0.1 point-to-point

ip address 10.23.23.3 255.255.255.0

frame-relay interface-dlci 232

!

interface Serial1

no ip address

encapsulation frame-relay

no keepalive

shutdown

clockrate 64000

!

interface Serial1.1 point-to-point

ip address 10.33.13.3 255.255.255.0

frame-relay interface-dlci 131

!

!

line con 0

line aux 0

transport input all

line vty 0 4

login

!

end


========================================


R2#sho run

Building configuration...


Current configuration : 682 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip audit po max-events 100

!

!

!

interface Ethernet0/0

no ip address

shutdown

half-duplex

!

interface Serial0/0

no ip address

shutdown

!

interface Serial0/1

no ip address

encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

ip address 10.23.23.2 255.255.255.0

frame-relay interface-dlci 232

!

ip http server

no ip http secure-server

ip classless

!


line con 0

line aux 0

line vty 0 4

!

!

end



========================================



R1#sho run

Building configuration...


Current configuration : 720 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

memory-size iomem 15

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip audit po max-events 100

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

half-duplex

!

interface Serial0/0

no ip address

encapsulation frame-relay

no keepalive

!

interface Serial0/0.1 point-to-point

ip address 10.13.13.1 255.255.255.0

frame-relay interface-dlci 131

!

interface Serial0/1

no ip address

shutdown

!

no ip http server

no ip http secure-server

ip classless

!

!

line con 0

line aux 0

line vty 0 4

!

!

end


cisco steps Thu, 06/25/2009 - 12:01

more info:




3#sho ip int b

Interface IP-Address OK? Method Status Protocol

Ethernet0 unassigned YES not set administratively down down

Serial0 unassigned YES not set up down

Serial0.1 10.23.23.3 YES manual down down

Serial1 unassigned YES not set up up

Serial1.1 10.33.13.3 YES manual up up


cisco steps Thu, 06/25/2009 - 12:42

here is also some more info that may make a since...




=========================================


R1#sho frame-relay pvc 131


PVC Statistics for interface Serial0/0 (Frame Relay DTE)


DLCI = 131, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0.1


input pkts 0 output pkts 70 in bytes 0

out bytes 23870 dropped pkts 0 in pkts dropped 0

out pkts dropped 0 out bytes dropped 0

in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

out BECN pkts 0 in DE pkts 0 out DE pkts 0

out bcast pkts 70 out bcast bytes 23870

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 01:36:26, last time pvc status changed 01:07:18



=========================================



R2#sho frame-relay pvc 232


PVC Statistics for interface Serial0/0 (Frame Relay DTE)


DLCI = 232, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0.1


input pkts 0 output pkts 23 in bytes 0

out bytes 6658 dropped pkts 0 in pkts dropped 0

out pkts dropped 0 out bytes dropped 0

in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

out BECN pkts 0 in DE pkts 0 out DE pkts 0

out bcast pkts 18 out bcast bytes 6138

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 00:17:56, last time pvc status changed 00:16:00


=========================================



R2#sho frame-relay map

Serial0/0.1 (up): point-to-point dlci, dlci 232(0xE8,0x3880), broadcast

R2#sho frame-relay lmi


=========================================


R1#sho frame-relay map

Serial0/0.1 (up): point-to-point dlci, dlci 131(0x83,0x2030), broadcast





cisco steps Thu, 06/25/2009 - 12:47

I made some changes ,, and if you look @ my troubleshooting .. I was able to get all the interfaces UP/UP , the only thing that I suspect is that both PVC STATUS= STATIC.. per my notes one should be STATIC and the other should be ACTIVE..


Thanks and I hope this is not too much of the info.



Edison Ortiz Thu, 06/25/2009 - 18:25

it seems that you want R3 to be the FR Switch, do the following config changes:


erase the entire config on R3 and enter the following:


frame-relay switching


int s0

description R1

clockrate 64000

no shut

frame-relay intf-type dce

frame-relay route 131 interface Serial1 232


int s1

description R2

clockrate 64000

no shut

frame-relay intf-type dce

frame-relay route 232 interface Serial0 131



On R2


interface Serial0/1.1 point-to-point

no ip address 10.23.23.2 255.255.255.0

ip address 10.13.13.2 255.255.255.0



cisco steps Fri, 06/26/2009 - 07:14


Edison ,


something is still wrong.. there is no communication , I have up /up on all interfaces...


Thanks


R2

=====

interface Serial0/0

no ip address

encapsulation frame-relay

no keepalive

!

interface Serial0/0.1 point-to-point

ip address 10.13.13.2 255.255.255.0

frame-relay interface-dlci 232



R3

=====


interface Serial0

description R1

no ip address

no fair-queue

clockrate 64000

!

interface Serial1

description R2

no ip address

clockrate 64000



R1

=====


interface Serial0/0

no ip address

encapsulation frame-relay

no keepalive

!

interface Serial0/0.1 point-to-point

ip address 10.13.13.1 255.255.255.0

frame-relay interface-dlci 131

cisco steps Fri, 06/26/2009 - 08:00

R3(config)#frame-relay switching

R3(config)#

R3(config)#int s0

R3(config-if)#description R1

R3(config-if)#clockrate 64000

R3(config-if)#no shut

R3(config-if)#frame-relay intf-type dce

%Serial0 :Frame Relay not configured on interface

R3(config-if)#frame-relay route 131 interface Serial1 232



%Serial0 :Frame Relay not configured on interface

======


I get this error !!!!!!!

Giuseppe Larosa Fri, 06/26/2009 - 09:48

Hello Octoirbust,



do


conf t

frame-rel switching

int ser0

enc frame-relay

frame-relay intf-type dce

frame-relay route 131 interface Serial1 232


Hope to help

Giuseppe


cisco steps Fri, 06/26/2009 - 11:26

Giuseppe ,


I changed my config so many times that I am lost right now.


can you pls help w/ full config for r1 , r2 and r3 ..can do it anymore.. I just get more confuse.


Thanks

cisco steps Fri, 06/26/2009 - 14:59

here is my current config


r1


interface Serial0/0

ip address 192.168.10.5 255.255.255.252

encapsulation frame-relay

no keepalive

serial restart-delay 0

frame-relay interface-dlci 103


r3

interface Serial0

ip address 192.168.10.6 255.255.255.252

encapsulation frame-relay

no keepalive

no fair-queue

serial restart-delay 0

frame-relay interface-dlci 103




r2

interface Serial0/0

ip address 192.168.10.10 255.255.255.252

encapsulation frame-relay

no keepalive

serial restart-delay 0

fair-queue

frame-relay interface-dlci 203



r3

interface Serial1

ip address 192.168.10.9 255.255.255.252

encapsulation frame-relay

no keepalive

serial restart-delay 0

frame-relay interface-dlci 203

Edison Ortiz Fri, 06/26/2009 - 15:43

I forgot to include encapsulation frame-relay in my previous post, my apologies - I was doing the commands from the top of my head.


Can you please go back to that config and include that command as well on R3?


It should work and R3 will become your FR Switch device.


jimmysands73_2 Fri, 06/26/2009 - 18:03

Using R3 as the FR Switch, and not being too sure of what the author was actually trying to do, here are my working configs below. From R1 I can ping R3 and vica versa. I used Cisco NetLabs for this fyi, so I couldnt change the cables, hence the DCE config on the FR switch and the clockrate on the R2 sw. And my ports changed alittle bit. I forgot one thing, why from R1 can I not ping R1? Would I need a fr map statement?


R1#ping 10.13.13.2


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.13.13.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms

R1#sh run

Building configuration...


Current configuration : 933 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 15

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface Serial0/1

ip address 10.13.13.1 255.255.255.0

encapsulation frame-relay

frame-relay interface-dlci 131

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

!

end


R2#ping 10.13.13.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.13.13.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms

R2#sh run

Building configuration...


Current configuration : 933 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 10

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

!

interface Serial0/1

ip address 10.13.13.2 255.255.255.0

encapsulation frame-relay

clock rate 64000

frame-relay interface-dlci 232

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!


!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

!

end


R3 configs in next post, this one too long.

jimmysands73_2 Fri, 06/26/2009 - 18:03

R3#sh frame-relay rou

Input Intf Input Dlci Output Intf Output Dlci Status

Serial0/0 131 Serial0/1 232 active

Serial0/1 232 Serial0/0 131 active

R3#sh run

Building configuration...


Current configuration : 1227 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 10

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

frame-relay switching

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

description R1

no ip address

encapsulation frame-relay

no fair-queue

clock rate 64000

frame-relay intf-type dce

frame-relay route 131 interface Serial0/1 232

!

interface Serial0/1

description R2

no ip address

encapsulation frame-relay

no fair-queue

frame-relay intf-type dce

frame-relay route 232 interface Serial0/0 131

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

transport input all

line vty 0 4

login

!

!

end


R3#



Edison Ortiz Fri, 06/26/2009 - 20:23

In order to ping the serial interface of R1 from R1, you need a frame-relay map statement pointing to the remote DLCI or you can use subinterfaces.


When pinging the local serial, the packet actually tries to exit the interface and since there isn't any mapping for that IP, it fails.


HTH,


__


Edison.

cisco steps Mon, 06/29/2009 - 10:07

ok , Thank you all for your help. got the frame-relay up and running,



Actions

This Discussion