multiple VLANs on Intel NIC Pro 1000 GT and trunks on 3560/3750 switches

Unanswered Question

I have a Cisco 3560 switch and I have configured a port as a trunk port like this:


switchport mode trunk

swithport trunk encapsulation dot1q


I also have an Intel Network card PRO 1000 GT in a desktop computer and I have configured multiple VLANs on the NIC. I cannot get them to work at all. I have tried different ports on the switch, a different switch (Cisco 3750) and still no luck.


The NIC works fine if I don't setup the VLANs on it. It also works fine if I setup an "untagged VLAN". (i.e. switchport trunk native vlan 100).


I called Intel and they seem to think it's a configuration problem on the Cisco switch.


I'm thinking the frames are being tagged differently somehow and that's why it's not working.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Tue, 06/23/2009 - 18:23
User Badges:
  • Purple, 4500 points or more

The native vlan must match on both sides,if you set up the trunk with a native vlan of 100 on the nic then the trunk setup on the switch must also be native vlan 100 in order for the trunk to work correctly.

Ok, I made a little progress. I setup an "untagged" VLAN on the NIC and then I also setup VLAN 260 on the NIC.


On the switch side, I setup VLAN 100 as the native VLAN. VLAN 260 seems to work as received a DHCP address on that VLAN. However, VLAN 100 didn't work at all.


Then I added VLAN 100 on the NIC side and still nothing on that VLAN.


Then I tried using VLAN 300 as the native vlan on the switch but that didn't work either.


The Intel NIC doesn't give you the option to specify a VLAN ID for the "untagged" native VLAN.


Any suggestions?

Actions

This Discussion