80211n with just 60 mbit per second

Answered Question
Jun 25th, 2009

Hello there,

we have a Cisco 2106 WLC with software version 5.1.151.0 and 2 LAP1252.

Everything is enabled for 802.11n, an Intel 4965 client is connecting correctly, shows that 300 mbit per second. But the real throughput (with the iperf-tool) is just 60mbit/s.

The client is working in 802.11a frequency-band and 40 mhz channel bandwidth. all 11n rates are enabled.

now the questions: what's wrong with it? did we forget something?

thanks for your answers.

greetings from germany

Franky

I have this problem too.
0 votes
Correct Answer by Mario de Molina... about 7 years 5 months ago

How are you testing the throughput? You will have different results if you test between a wired client and a wireless client (best in this case) or between two wireless clients.. Also you will have better results if you use UDP or if you open several connections..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
dancampb Thu, 06/25/2009 - 05:29

Keep in mind that with a 2106 controller you are going through a 10/100 port. The traffic goes from the AP to the controller, is unencapsulated, and put out on the wire. So basically the 10/100 port on the controller will be a bottleneck. You may want to try putting the AP in H-REAP mode and locally switching that WLAN. That way the traffic wouldn't have to got through the controller.

Frank Lindner Thu, 06/25/2009 - 06:33

Hi there, thanks for your response.

I allready activated this, so traffic isn't sent to the controller. I checked this also with wireshark and a mirrored port on the switch.

Correct Answer
Mario de Molina... Sat, 07/11/2009 - 20:20

How are you testing the throughput? You will have different results if you test between a wired client and a wireless client (best in this case) or between two wireless clients.. Also you will have better results if you use UDP or if you open several connections..

Frank Lindner Sun, 07/12/2009 - 01:21

i use iperf in tcp-mode for testing. from a wireless client to a wired client. the traffic just goes from client to ap, from ap to switch, from switch to a pc.

tcp-mode in iperf puts maximum possible through the network.

your tip with serveral connections i will try this week.

thanks this time.

Robert.N.Barrett_2 Wed, 07/15/2009 - 09:14

You'll never get anywhere close to the 300mbps over wireless. The number is sort of a "raw" throughput speed. Wireless protocol overhead will make a significant impact on that. For example, a single 802.11g client with a 54mbps connection to the AP will only show up as about 18 on iperf.

I'm not saying that 802.11n would suffer the same level of performance difference as 802.11g, but 54 raw/18 actual would work out to about 300 raw/100 actual if it were.

You also need to ensure you are operating in a "clean" wireless environment to achieve the best throughput in your tests (the best speed would be achievable only when there is one AP and one wireless client and nothing else using that frequency).

Robert.N.Barrett_2 Wed, 07/15/2009 - 09:51

I think you're also losing some throughput due to the fact that you cannot enable 802.11n "Greenfield" mode, which means that the AP is still set to support 802.11a/g clients.

Frank Lindner Wed, 07/15/2009 - 12:04

we have a clean environment, i prooved it with a spectrum-analyzer. in g-mode, i get something about 22 mbit/s und in a-mode 22 mbit/s too, sparely up to 23 mbit/s.

i also allready had disabled the datarates 1 to 54, but this doenst cange anything on the troughput. all interfaces, except the 5 ghz, are disabled. all tx and rx antennas are activated.

and i won't get 300 mbit/s. thats true, that this can't be reached. But up to 140mbit/s should be possible.

Robert.N.Barrett_2 Wed, 07/15/2009 - 13:13

When I tested this a few weeks ago, I could not disable all the data rates between 1 and 54. One would always remain enabled, which meant my AP remained in "mixed mode" 802.11a/n. I confirmed this behavior with Cisco (I was using a 4402 with 5.2.x.x code).

I also cannot disable all the 1 through 54 data rates on an autonomous 1252.

Frank Lindner Wed, 07/15/2009 - 21:23

i could disable all rates. i also updated from 5.1.x.x to 6.2.x.x (the newest version avaible) but also didn't made any changes

andrewswanson Wed, 07/22/2009 - 02:26

had a similar issue with disappointing data rates for 802.11n on a WLC 4404. i was filtering traffic on the WLC using ACLs and as soon as i removed these ACLs the data rates i got for 802.11n rose dramtically.

posted results on forum:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=Security%20and%20Network%20Management&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cc26b59/5#selected_message

ended up removing ACLs from WLC and filtering wireless VLANs elsewhere. Cisco responded saying that the ACLs on the WLC shouldn't introduce any latency but i tried this with a number of different software revs

hth

andy

Frank Lindner Wed, 07/22/2009 - 09:01

thanks for your response.

if i don't make a misstake, you receive about 50mbit/s (54xxx kbit/s), right?

that is the same as i have in my environment. but i need to get a bit more. something around 100mbit/s. but i will have a look tomorrow on the ACL.

Thanks.

Frank Lindner Thu, 07/23/2009 - 01:00

Thanks to everyone who helped me.

I made multiple TCP connections (best results with 8 parallel) and now i receive about 140 Mbit/s! Some peaks go up 153 Mbit/s. That's great and that's what i wanted.

diek Thu, 07/23/2009 - 12:13

I have a AP1252AG just installed and with ver 12.4. It has a 2.4GHz and a 5GHz module installed. With a single client next to it I get a 54Mbps Max. Could you explain what configuration needs to be done to get to where you said "Everything is enabled for 802.11n."

Thanks

Ken

Frank Lindner Thu, 07/23/2009 - 12:22

On non controller based controller they are called MCS-rates 1 to 15. Its on same page on the webinterface, where you can enable and disable the a- or g- rates.

diek Mon, 07/27/2009 - 05:08

Thanks for your response on setting up 802.11n access. I set my 5GHz radio MCS to 15 only and I still only get 54Mbps max to a Dell Wireless 1510 Wireless-N WLAN MiniCard. Attached is how my radios are conf on my 1252.

Thanks,

Ken

Frank Lindner Mon, 07/27/2009 - 08:10

Did you enable 40 Mhz channel bandwidth and client link feature? did you also enable all antennas?

diek Mon, 07/27/2009 - 10:10

40Mhz channel is enabled on the 5Ghz module and all six antennas are enabled with the Receive and Transmit Antenna set to diversity. This can be seen on the attached snapshot of both module configuration on my last post message.

What is Client Link Feature?

Frank Lindner Mon, 07/27/2009 - 22:18

Don't know if this feature exists on autonoums AP also, but I can enable this on the 802.11b/g/n Network page and on the 802.11a/n Network page.

But as i had seen on your screenshot, the webinterfaces are a bit different between LAP and AP. You may need to search a bit for it, it should exist.

Another tipp could be to disable the 2,4 ghz interface. Just enable 5 Ghz with 40 Mhz channel bandwidth.

Is your client setted correctly? The n-feature is enabled in driver settings. What displays the status windows of your Dell client? It should display the 40 Mhz and 2x2 Tx / Rx for antennas.

mervw Thu, 07/30/2009 - 14:36

Hi Franky

I am having a similar issue, any chance of getting a copy of your config so we can compare.

Thanks

Merv

diek Fri, 07/31/2009 - 05:12

Thanks for the add info on this and I am sorry for not getting back to you sooner.

There is no client link feature on the 1252. Diabling the 2.4 ghz interface did not help.

I enabled a 40Mhz option on the client but still only getting 54Mbps max speed.

Ken

Frank Lindner Sat, 08/01/2009 - 00:15

hi diek,

but i don't know, why the standalone 1252 doesn't have this feature. it should be there. but the config-web-interface isn't similar to the controller-based. had you allready take a look in the config manual from cisco? maybe search the pdf-file for this feature.

Frank Lindner Sat, 08/01/2009 - 00:12

hi marvw,

i try to take some time next week. but i have many other projects to work on or i'm on business travel.

maybe you can post me your email-address so that i can mail this to you.

Robert.N.Barrett_2 Sun, 08/02/2009 - 04:54

If this is a controller you use for testing, would you be able to upgrade to the 6.x code base and let us know if the performance improves? I have heard from Cisco that 6.0 is "faster" than 5.2, which is faster than 5.1 (with 802.11n).

It would also be great if you could test with something besides an Intel card.

Frank Lindner Sun, 08/02/2009 - 07:00

i have upgraded to 6.x and also tested with a broadcom card. now works fine. i just need to make several parallel connections with iperf for example. FTP transfer is done with around 100 mbit/s. that's what i want.

diek Mon, 08/03/2009 - 07:00

dasfranky

I thought you fixed your problem on the July 23 when you said you were now getting 140Mbps. Now on Aug 2 you upgraded to 6.x and said the broadcom card works. What fixed your problem?

My 1252 is attached to a C3570G-48TS-S

and not a standalone. When you say "the config-web-interface isn't similar to the conroller based" do you consider controller based config to be command line configuration?

diek Mon, 08/03/2009 - 12:29

I got my 1252 setup to support an 802.11n device at 270Mbps using the following steps from Cisco Support.

1. At least 3 antennas must be enabled.

2. In the 5 ghz band all MCS rates must be enabled

3. Security should be either WPA2-AES or an open authentication.

4. Enable wmm.by going to Services then QoS and then under Advanced enable wmm

5. Channel Bonding is set under Network Interfaces Radio1 Settings with Channel Width set to Above 40 MHz

I had to also upgrade the 1252 System

Software Version to 12.4(10b)JDA3 from 12.4(10b)JA1.

Frank Lindner Mon, 08/03/2009 - 21:34

Yes, I solved it. earlier i only got about 70mbit/s. now, with more parallel data-streams, i achiev about 140 mbit/s.

i have 2 intel 4965 and 1 braodcom **** (don't know the model right now) integrated in laptops.

during the my tests i had to upgrade to v 6.x because we have some 1142 AP and they doesn't worked with the v5.x controller version. our controller is a 2106 WLC.

i'm sorry, but with command line a can't help you. i'm not that "pro" in CLI. maybe i can copy my config and send it to you.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode