ISDN BRI Backup

Unanswered Question
Jun 25th, 2009

Does any body are already configure a ISDN BRI Interface as backup line for Serial connection?

I have two site that must be connect with ISDN BRI whe the main serial ling goes down.

Does any bony have a example ?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Afragoso2009 Thu, 06/25/2009 - 10:37

I had congifure the remote site

but I am seeing that its not dialing when I put the serial line down even the interface dialer goes up

I ahve the following configuration on the remote router

interface Serial0/0/0

ip address 192.168.253.14 255.255.255.252

ip accounting output-packets

ip accounting precedence input

ip accounting precedence output

ip nbar protocol-discovery

!

interface BRI0/1/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface Dialer1

no ip address

encapsulation ppp

dialer pool 1

dialer string 2601424

dialer string 2601425

dialer-group 1

ppp authentication chap



Giuseppe Larosa Thu, 06/25/2009 - 11:13

Hello Antonio,


your Dialer1 interface should have an ip address: a backup link is still an IP link


it is not possible to route ip traffic over an interface where IP is disabled


in this context you can assign a private ip subnet to the DDR service and you can give static ip addresses to the two sites.


Hope to help

Giuseppe


Dennis Mink Thu, 06/25/2009 - 21:35

and make sure you set the admin distance of the static route to 200, otherwise everything will go across you dialer, causing a high telephone bill!


so ip route 0.0.0.0 0.0.0.0 dialer 1 200 (for instance)

Afragoso2009 Tue, 06/30/2009 - 09:10

Hi everybody

I add an IP address to the dialer interface.

But when I put the main serial down the dialing its not happennig :


*Jun 30 16:48:33.693: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.253.1

3 (Serial0/0/0) is down: holding time expired

*Jun 30 16:48:55.393: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/

0, changed state to down

*Jun 30 16:48:55.397: %LINK-3-UPDOWN: Interface BRI0/1/0:1, changed state to dow

n

*Jun 30 16:48:55.397: %LINK-3-UPDOWN: Interface BRI0/1/0:2, changed state to dow

n

*Jun 30 16:48:55.449: %LINK-3-UPDOWN: Interface BRI0/1/0, changed state to up

RT_AGN_ASA#

RT_AGN_ASA#

RT_AGN_ASA#

*Jun 30 16:51:35.393: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/

0, changed state to up

*Jun 30 16:51:35.453: %LINK-5-CHANGED: Interface BRI0/1/0, changed state to stan

dby mode

*Jun 30 16:51:35.453: %LINK-3-UPDOWN: Interface BRI0/1/0:1, changed state to dow

n

*Jun 30 16:51:35.453: %LINK-3-UPDOWN: Interface BRI0/1/0:2, changed state to dow

n

*Jun 30 16:51:35.797: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.253.1

3 (Serial0/0/0) is up: new adjacency





vmiller Tue, 06/30/2009 - 13:25

Did you add the static route ?

Have you verifyed the ISDN switch type with the carrier ?

smothuku Wed, 07/01/2009 - 01:20

Hi below is the config...


End - A :


interface Serial0/0/0

ip address 192.168.253.14 255.255.255.252

ip accounting output-packets

ip accounting precedence input

ip accounting precedence output

ip nbar protocol-discovery

!

interface BRI0/1/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface Dialer1

ip address 10.10.10.1 255.255.255.252

encapsulation ppp

dialer pool 1

dialer caller 2601424

dialer caller 2601425

dialer-group 1

ppp authentication chap


ip route 0.0.0.0 0.0.0.0 192.168.253.15

ip route 0.0.0.0 0.0.0.0 10.10.10.2 200



End - B config :


interface Serial0/0/0

ip address 192.168.253.15 255.255.255.252

back-up interface bri 0/1/0



interface BRI0/1/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface Dialer1

ip address 10.10.10.2 255.255.255.252

encapsulation ppp

dialer pool 1

dialer string 2601424

dialer string 2601425

dialer-group 1

ppp authentication chap



ip route 0.0.0.0 0.0.0.0 192.168.253.14

ip route 0.0.0.0 0.0.0.0 10.10.10.1 200


check with your provider about switch type which needs to configures on bri interface.


Thanks,

Satish


Afragoso2009 Wed, 07/01/2009 - 09:00

Hi Smot

Thanks for your help . I put the configuration you sugest but my BRI (End - B config ) its still no dialing whe the Serial goes down


Just to confirm , my switch type is net3


route2null Wed, 07/01/2009 - 19:01

Can you actually make a call over the BRI? Forget the config for the moment and use an interactive command to test. Turn on debug q931 and term mon (Or log con) then issue this command...


isdn test call int b0/1/0 xxxxxxxxxx


xxxxxxxxxx = the number you are trying to call.


View the debug output to confirm its even trying to call.

chinkevi_2 Wed, 07/01/2009 - 21:39

hello,


i think you better first manually test the isdn service before test the backup function.


- under bri interface, you need ppp authentication too.

- you need to send chap username password in dialer interface.

- you need local user database to authenticate remote device.


your floating static would be better this way:

ip route 0.0.0.0 0.0.0.0 10.10.10.1 200

ip route 10.10.10.1 255.255.255.255 dialer1


also, please provide sh isdn service and debug isdn q931 when dialing. Preferably in attachment.


Afragoso2009 Thu, 07/02/2009 - 02:39

Hi team

This is the result off my isdn call teste


*Jul 2 10:40:28.387: ISDN BR0/1/0 **ERROR**: handle_l2d_srq_mail: Layer 1 inact

ive

*Jul 2 10:40:36.387: ISDN BR0/1/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

*Jul 2 10:40:36.387: ISDN BR0/1/0 **ERROR**: host_disconnect_ack: Call rejected

cause Temporary failure(0x29) call id 0x8004


chinkevi_2 Thu, 07/02/2009 - 05:11

hello,

we need "sh isdn service" and full debug of "debug isdn q931" from start.

pompeychimes Thu, 07/02/2009 - 06:59

You do have layer 1 and 2 right? Post the output from the "show isdn status" command please.

Afragoso2009 Thu, 07/02/2009 - 11:10

Please see in atach what I having now

I am now able to dial , only when I remove the "dialer pool-member 1" on the interface BRI 0/1/0 and put it back again

chinkevi_2 Thu, 07/02/2009 - 14:43

Afragoso2009,


please try to attachment again.

the show command we are after is "show isdn status". my apology, i put in the wrong command before.

chinkevi_2 Thu, 07/02/2009 - 16:31

hello,

the good news is isdn does connect.

the disconnection must be caused by ppp negotiation.


so please test again with "debug isdn q931" and "debug ppp negotiation"


Afragoso2009 Fri, 07/03/2009 - 01:56

Hi Chinkevi

See in attach the ppp negotiation and authentication


But why the dialing only star when I remove the "dialer pool-member 1" and put it back again on the interface BRI on the caller site ?

pompeychimes Fri, 07/03/2009 - 04:46

So it appears the chap process isn't completing because you don't have "username rt-core2-1000 password ******" configured on RT_AGN_ASA and/or you don't have "username RT_AGN_ASA password ******" configured on rt-core2-1000.


Regarding your other problem I don't see (Maybe i overlooked it?) how you are defining interesting traffic. For example do you have "dialer-list 1 protocol ip list 101" and "access-list 101" configured?


James

chinkevi_2 Fri, 07/03/2009 - 04:53

i guess when you reinsert the pool command cause dialer interface up.


but you can just use ping direct to remote dialer ip to bring up the isdn, depends on your interesting traffic setup.


ppp failed in authentication phase and it is 2 way authentication. You can remove ppp authentication in bri and dialer config on both sides, or apply the following on both routers:


local router - username rt-core2-100 password xxxx


remote router - username RT_AGN_ASA password xxxx


int dialer x

! send username/password

ppp chap hostname

ppp chap password



from memory if you don't specify username to send, router will use its hostname as username.


if isdn fail again, check the ppp debug again for CHAP phase to be success or fail. After authentication is the IPCP.


Afragoso2009 Fri, 07/10/2009 - 05:14

Great

I remove the ppp authentication and its work fine now

My question now its how to have the 128 k working? I means both B channel at the same time?

Actions

This Discussion