WIC 4ESW and routing

Unanswered Question
Jun 26th, 2009

Hi All,

I have a 1721 router with a WIC 4ESW 4 port switch card and an integrated T1 controller.

I have a T1 to the core of my network going into this Cisco 1721 router. I need have all the devices plugged into the 4 port switch on one network and the T1 controller on another network. These two networks converge at the 1721 router. When I plug the router in eigrp advertises the route of the serial interface that is directly connected. The problem that I am looking to solve is how can I get the network that I am using for the 4 port switch to advertise?

below is my config.

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname

!

boot-start-marker

boot system flash c1700-ipbasek9-mz.124-25a.bin

boot-end-marker

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login telnet local

!

aaa session-id common

clock timezone est -5

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.143.0.0 10.143.2.0

ip dhcp excluded-address 10.143.2.4 10.143.255.255

!

ip dhcp pool 143

network 10.143.0.0 255.255.0.0

default-router 10.143.1.254

lease 0 8

!

!

no ip bootp server

no ip domain lookup

!

!

!

!

!

!

interface FastEthernet0

no ip address

speed auto

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface Serial0

ip address 192.168.143.2 255.255.255.0

!

interface Vlan1

ip address 10.143.1.1 255.255.0.0

!

router eigrp 1

network 10.0.0.0

network 192.168.143.0

no auto-summary

no eigrp log-neighbor-changes

!

ip default-gateway 10.143.1.254

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.143.1

!

no ip http server

no ip http secure-server

!

control-plane

!

!

line con 0

login authentication telnet

line aux 0

line vty 0 4

login authentication telnet

!

ntp server 10.220.42.200 prefer

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Fri, 06/26/2009 - 16:42

The 4 ports belong to Vlan 1 and you have an IP address under Vlan 1.

This address is already under the EIGRP process.

Are you saying the remote EIGRP neighbors aren' receiving this route?

Can you post the show ip route from this router and remote neighbors?

___

Edison.

Richard Burts Sun, 06/28/2009 - 10:58

Roy

Edison is correct that your EIGRP should advertise the network of the VLAN. One thing that is necessary for that to happen is for the VLAN to be in an up/up state. Can you post the output of show ip interface brief to verify whether the VLAN is up?

HTH

Rick

resoh Mon, 06/29/2009 - 04:04

Looks like vlan 1 is up/down

#sh ip int bri

Interface IP-Address OK? Method Status Protocol

FastEthernet0 unassigned YES NVRAM up down

FastEthernet1 unassigned YES unset up down

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

FastEthernet4 unassigned YES unset up down

Serial0 192.168.143.2 YES NVRAM up up

Vlan1 10.143.1.1 YES NVRAM up down

Edison Ortiz Mon, 06/29/2009 - 04:35

One of those ports (F0 - F4) needs to be up/up for Vlan 1 to be up/up.

Once Vlan 1 is up/up, it will be advertised into EIGRP.

HTH,

__

Edison.

resoh Mon, 06/29/2009 - 06:14

The vlan 1 interface comes up when I plug in a device, and the route to the 10.143.0.0 network shows up. I can now ping from the remote 10.143.0.0 network to the core but I can not ping from the core to the remote network 10.143.0.0 network. I can ping the router serial interface 192.168.143.2 from the core, but I can't ping a device on the 10.143.0.0 network. I am able to ping interface vlan 1 ip address 10.143.1.254

BTW i changed the interface vlan 1 ip address to 10.143.1.254 (it was 10.143.1.1)

Edison Ortiz Mon, 06/29/2009 - 07:23

If you can ping from a client in the 10.143.0.0/16 subnet to the core but you are unable to ping from the core back to the client, I suggest to make sure the client does not have any FW enabled.

__

Edison.

Edison Ortiz Mon, 06/29/2009 - 09:02

You could have overlapping subnets somewhere in your routing table.

Check the routing table from the Core and make sure it goes to the respective spoke.

__

Edison.

Actions

This Discussion