bgp issue urgent

Answered Question
Jun 26th, 2009
User Badges:
  • Purple, 4500 points or more

I have a site that shares the same public block, and at that site I have a route map that sets a metric to higher than our current site. I'm trying to connect to the public side, but I randomnly get there and I know why.


The pertinent parts are:


int s0/1

ip address 6.6.6.1 255.255.255.252



access-list 10 permit 5.5.5.0 0.0.0.127


route-map ADV permit 5

match ip address 10

set metric 100

set community x:x



router bgp 5

network 6.6.6.0 mask 255.255.255.252

network 5.5.5.0 mask 255.255.255.128

neighbor 1.1.1.1 send-community

neighbor 1.1.1.1 route-map ADV out


The problem is that I have a Fatpipe that all of my links come into at my main site. The traffic outbound can go out any one of those links. I realize that when it goes over the second link, it's not allowing me to get to the router and I think it's my route map.


Should I also create:


route-map ADV permit 20


and leave it blank? I don't think the 6.6.6.0 subnet is getting advertised.


Thanks!

John

Correct Answer by Edison Ortiz about 7 years 10 months ago

It is not and your deduction is the correct one.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Edison Ortiz Fri, 06/26/2009 - 12:47
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

It is not and your deduction is the correct one.

John Blakley Fri, 06/26/2009 - 12:50
User Badges:
  • Purple, 4500 points or more

Thanks Edison. I'll be fixing it tonight.

Edison Ortiz Fri, 06/26/2009 - 12:54
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Good luck. Routes not matching ACL 10 were being processed by the implicit deny on such route-map. That will always get you :)

Actions

This Discussion