same-security access problem

Unanswered Question
Jun 29th, 2009

I'm trying to set-up two networks on two separate ASA ports and make them communicate with each other. I'm using the same security level (100) for them and I've checked the option for same-security level communication in ASDM. The problem is that I can't make this scenario work. The ASA interfaces are reachable from their networks but I can't ping between them(across the ASA). ACLs are set on permit any and I've set up also nat exemptions. The packet tracer shows no problem but ping or traceroute doesn't work. I also enabled icmp inspection. It's driving me crazy. Anyone know what I'm missing here? There is also a third interface used for internet access with NAT and it works.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
robertson.michael Mon, 06/29/2009 - 12:19

Hi Sergiu,

Can you post a sanitized version of your config? This will help us troubleshoot your issue.

Other than that, I would suggest setting up some packet captures to see exactly where the traffic is failing. This may give you a hint about where you should start your troubleshooting. Take a look at the 'capture' and 'show asp drop' commands:

'capture' Command Reference:

http://www.cisco.com/en/US/docs/security/asa/asa80/command/reference/c1.html#wp2108895

'show asp drop' Command Reference:

http://www.cisco.com/en/US/docs/security/asa/asa80/command/reference/c1.html#wp2108895

Hope that helps.

-Mike

sergiu.campian Mon, 06/29/2009 - 22:07

Here's my current lab config (I replaced the real IP addresses). I'm trying to communicate between 192.168.1.0/24 and 172.16.0.0/24

ASA Version 8.0(4)

names

name 192.168.1.1 server

!

interface Ethernet0/0

nameif inside

security-level 100

ip address 192.168.1.254 255.255.255.0

!

interface Ethernet0/1

nameif wan2

security-level 0

ip address X.X.X.X 255.255.255.0

!

interface Ethernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/3

nameif vodafone

security-level 100

ip address 172.16.0.2 255.255.255.0

!

ftp mode passive

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

access-list inside_nat_outbound extended permit ip 192.168.1.0 255.255.255.0 any

access-list inside_access_in extended permit ip any any

access-list wan2_access_in extended permit ip any any

access-list vodafone_access_in extended permit ip any any

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 17

2.16.0.0 255.255.255.0

access-list inside_access_out extended permit ip any any

access-list vodafone_access_out extended permit ip any any

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu wan2 1500

mtu vodafone 1500

mtu management 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-613.bin

no asdm history enable

arp timeout 14400

nat-control

global (inside) 1 interface

global (wan2) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 192.168.1.0 255.255.255.0

static (inside,wan2) X.X.X.X server netmask 255.255.255.255

static (inside,inside) X.X.X.X server netmask 255.255.255.255

access-group inside_access_in in interface inside

access-group inside_access_out out interface inside

access-group wan2_access_in in interface wan2

access-group vodafone_access_in in interface vodafone

access-group vodafone_access_out out interface vodafone

!

router rip

network 172.16.0.0

passive-interface inside

passive-interface wan2

version 2

!

route wan2 0.0.0.0 0.0.0.0 Y.Y.Y.Y

route inside 172.16.0.0 255.255.0.0 172.16.0.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.0.0 255.255.0.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

vpn-addr-assign local reuse-delay 1

telnet timeout 5

ssh timeout 5

console timeout 0

management-access inside

dhcpd address 192.168.1.15-192.168.1.250 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

!

class-map global-class

match any

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum 512

policy-map type inspect dns MY_DNS_INSPECT_MAp

parameters

message-length maximum 512

policy-map global_policy

class inspection_default

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

inspect dns MY_DNS_INSPECT_MAp

class global-class

inspect icmp

!

service-policy global_policy global

prompt hostname context

robertson.michael Tue, 06/30/2009 - 05:12

Hi Sergiu,

I copied your config into my test ASA and was able to ping across without any issues.

I would suggest checking the routing tables of the clients that you are pinging between to make sure they are correct (in a simple topology they would probably have a default route of the appropriate ASA interface). You can check this with the 'route print' command on Windows or the 'route' command on Linux.

I would also set up a few captures on the ASA to see where the ping is actually failing. You might setup something like this:

access-list ping-acl permit icmp 172.16.0.0 255.255.255.0 192.168.1.0 255.255.255.0

access-list ping-acl permit icmp 192.168.1.0 255.255.255.0 172.16.0.0 255.255.255.0

capture capin access-list ping-acl interface inside

capture capvod access-list ping-acl interface vodafone

capture drop type asp-drop all

Once you have these captures configured, try pinging again. Then:

'show capture capin' will show you which packets hit the inside interface

'show capture capvod' will show you which packets hit the vodafone interface

'show capture drop' and 'show asp drop' will show you which packets were dropped by the ASA and the reason for the drop

Here are a few command references:

'capture':

http://www.cisco.com/en/US/docs/security/asa/asa80/command/reference/c1.html#wp2108895

'show asp drop':

http://www.cisco.com/en/US/docs/security/asa/asa80/command/reference/c1.html#wp2108895

Let us know what you find.

-Mike

Actions

This Discussion