Interface problem

Unanswered Question
Jun 29th, 2009

Hi

I have strange problem with ports of my Cisco 4507R-E switch. Sometimes is happened when I look in my CUCM 6.1 to see that one or more phones are not registered. I telnet to 4507R switch to see status of port where IP Phone is connected show ip interface brief and the port is UP. Next thing I write following command show mac address-table interface gigabit 1/18 and there no mac address in output. The configuration of the ports is:

interface GigabitEthernet1/18

switchport mode access

switchport voice vlan 50

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

auto qos voip cisco-phone

qos trust device cisco-phone

macro description cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input AutoQos-VoIP-Input-Cos-Policy

service-policy output AutoQos-VoIP-Output-Policy

When I enter commands shutdown and no shutdown on the port interface and after that I enter show mac address-table interface gigabit 1/18 I can see the mac address of devices attached to the port.

VLAN

1 ------ PC

50 -------- IP Phone

and the PC and Phone take IP and everything is OK.

Any idea what can be the problem ?

The IOS is 12.2

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bwilmoth Mon, 07/06/2009 - 05:46

When a packet gets routed, it carries the source MAC address as that of the physical interface or VLAN interface, which performs the routing rather than the outgoing interface which is in switchport mode.

In order to learn the MAC address of the directly connected interface or port, you can configure the port for native VLAN. When any untagged frames are sent out of this port, the source MAC address associated physical port is learned and added to the MAC address table in the remote device.

http://www.cisco.com/en/US/products/hw/switches/ps663/products_tech_note09186a008011e6b4.shtml#interface_problems

Actions

This Discussion