Cisco AP1231G as WGB - %DOT11-4-CANT_ASSOC error message

Unanswered Question
Jun 30th, 2009

I have a Cisco AP1231G with autonomous IOS running in WorkGroup Bridge (WGB) mode.


However I can't get the device to associate with the root AP; which is a non-Cisco AP, and get the following error message.


%DOT11-4-CANT_ASSOC: Interface Dot11Radio0, cannot associate: WPAIE Invalid unicast suite count: 2



I've scanned Cisco documentation and run searches but I cannot find a doc that explains the cause of this error.


config extract below from Cisco WGB:


!

dot11 ssid TEST

authentication open

authentication key-management wpa

infrastructure-ssid

wpa-psk ascii 0 MY-PSK

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid TEST

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

power local cck 50

station-role workgroup-bridge

rts threshold 2312

l2-filter bridge-group-acl

bridge-group 1

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dancampb Tue, 06/30/2009 - 05:54

Bridging and WGB for the most part is not part of the 802.11 standards. Each vendor may do it a little different. What you probably want to try is to set this AP as a universal WGB. This mode the AP looks more like a client to the AP instead of a WGB.

dazza Tue, 06/30/2009 - 06:01

I can't configure

'station-role workgroup-bridge universal ...'

on the current IOS 12.3(8)JEA so I'll download a later IOS release to see if lets me set that parameter

dazza Wed, 07/01/2009 - 03:52

WGB universal mode does not appear to be supported on Cisco AP1231G even using the latest IOS image 123-8.JEC3 for that model.


Is that the case?


The Configuration Guide for 12.3(8)JEC suggests it is available for the 1200

http://www.cisco.com/en/US/docs/wireless/access_point/12.4_10b_JA/configuration/guide/scg12410b-chap6-radio.html#wp1178578



BUT....previous IOS config guides (12.3(8)JEB) for the 1200 say that universal WGB mode is NOT supported on 1200

http://www.cisco.com/en/US/docs/wireless/access_point/12.4_3g_JA/configuration/guide/s43rf.html#wp1178578



So...is universal mode supposed to be supported on the 1231 model or is the latest IOS documentation incorrect?

Actions

This Discussion