WCS6.0.132.0 Startup Error after Installation

Unanswered Question
Jun 30th, 2009

I installed WCS6.0.132.0 on a Win2k3 SP2 Engine for the first time. But as I started the WCS service I got an error.

It seems that the health monitor would not start.

As the WCS6.0.132.0 would not work I installed WCS5.2.148.0 and it works now.

In the install log I found a non fatal error:

Custom Action: com.cisco.packaging.SystemRequirementsCheck

Status: ERROR

Additional Notes: ERROR - class com.cisco.packaging.SystemRequirementsCheck.install() runtime

Until now I have not found any bug IDs for WCS6.0.132.0.

I use Win2k3 SP2 English with German language and keyboard settings.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Dirk Woellhaf Wed, 07/01/2009 - 04:07

Hi,

faceing the same error.

Looks like it is an Java-error.

Check your

\webnms\logs\hm_launchout.txt

if you have Heap-Size errors,too.

Reinstalling from scratch right now.

alois.heilmaier... Wed, 07/01/2009 - 04:15

Hi Dirk,

youre right it was a java error. I contacted our sales engineering team. I got following working solution.

I changed a section in file WCS6.0.132.0\bin\startServer.bat:

Old: set JAVA_OPTS=-server -Xms256m -Xmx%MAX_HEAP_SIZE% -XX:MaxPermSize=256m -Xrs -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=logs

New: set JAVA_OPTS=-server -Xms256m -Xmx1024m -XX:MaxPermSize=256m -Xrs -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=logs

Dirk Woellhaf Wed, 07/01/2009 - 04:31

Is working.

I just modified the statement:

old: set MAX_HEAP_SIZE=m

new: set MAX_HEAP_SIZE=1024m

It's working now.

Enjoy your day!

nboulet Wed, 07/29/2009 - 14:23

Hello,

I have the same problem with the HealthMonitor Service, but on the linux version.

here the hm_launchout.log

"

more hm_launchout.txt

JAVA_HOME=./../jre

Starting Health Monitor as a primary

Checking for Port 8082 availability... OK

Starting Health Montior Web Server...

Health Monitor Web Server Started.

Starting Health Monitor Server...

Health Monitor Server Started.

Starting WCS Server

Invalid maximum heap size: -Xmxm

Could not create the Java virtual machine.

"

where i have to modify the java option under linux redhat ?

Lucien Avramov Wed, 07/29/2009 - 20:55

startServer.sh in /opt/WCSx.x/bin

export JAVA_OPTS="-server -Xms256m -Xmx1024m -XX:MaxPermSize=256m -Djava.awt.hea

dless=true"

nboulet Wed, 07/29/2009 - 21:30

Ok thanks it works. The bin folder was hidden with the default installation.

Actions

This Discussion